Announcement

Collapse
No announcement yet.

Depriated error with fresh install of 3.7.2 patch level 2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Depriated error with fresh install of 3.7.2 patch level 2

    This thread describes what I am experiencing but I'm not able to reply to bump it for a question:

    http://www.vbulletin.com/forum/forum...priated-errors

    I'm trying to do a fresh install of 3.7.2 patch level 2. I have an owned license for it. I need to do a complete restore from my backup then I plan on upgrading to the most current version.

    I'm getting the following errors at the log in screen at install.php:
    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/install/init.php on line 44

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/install/init.php on line 83

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/install/init.php on line 91

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/install/init.php on line 171

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/install/init.php on line 183

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/includes/class_core.php on line 2518

    Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/content/98/11892698/html/Forum/includes/class_core.php on line 1637

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/includes/functions.php on line 875

    Deprecated: Assigning the return value of new by reference is deprecated in /home/content/98/11892698/html/Forum/includes/functions.php on line 879

    I'm using GoDaddy and have PHP v5.3 installed and MySQL v5.5. I can't even enter the the install system using my customer #.

    That thread mentions turning off Notice Error Reporting but I am unsure how to do this? Can someone please give me a hint? Is this done in myPHP admin somewhere?

    Thanks!

    Alex

    EDIT: I found a post that says this:

    "You can disable display_errors
    In your config.php file set ini_set(display_errors, 0);
    This will prevent other helpful error messages from showing, but it will disable those notices. "

    But I see no option like that in my config.php file...

    EDIT 2: I also found this:

    "Open the install.php file and find:
    PHP Code:
    error_reporting(E_ALL & ~E_NOTICE);

    Remove that line, or set it to 0 (should disable all) "

    But doing that seems to do nothing.
    anguilla1980
    Senior Member
    Last edited by anguilla1980; Tue 8 Oct '13, 11:37am.

  • #2
    I have godaddy also and I have this in php info page:
    magic_quotes_gpc On On
    magic_quotes_runtime Off Off
    magic_quotes_sybase Off Off
    Maybe this will help you!
    Cu Respect / Best Regards / Mit freundlichen Grüßen

    roStyles Design LLC
    CEO & Founder (Design and Support)
    Romanian Translator
    Teascu Dorin
    [email protected]
    https://www.rostyles.com

    Comment


    • #3
      Thanks. I also read that I need to have my host "Turn of show_errors errors in php.ini." according to this:
      http://tracker.vbulletin.com/browse/VBIII-12512

      I'm on the phone with GoDaddy to have them do this right now...

      EDIT: So they said since I'm on a Linux platform, I just need to create a file named php5.ini and upload it to my root directory. That file should contain the line of code that I want changed, in this case turning off show_errors, and they said that should do it.

      My problem now, I have this blank php5.ini file and have no clue what so ever what to put into it. Can anyone provide me with the code that I just need to paste into it?

      Ok help me out here guys, I have no clue about php code lol. Does this look correct for the body of this php5.ini file?

      <?php

      // Turn off all error reporting
      error_reporting(0);

      // Same as error_reporting(E_ALL);
      ini_set('display_errors',0);

      ?>

      Grrrr, I must be missing something because that still has no effect Help! Just need to get my forum installed and restored ASAP. Thanks!
      anguilla1980
      Senior Member
      Last edited by anguilla1980; Tue 8 Oct '13, 12:11pm.

      Comment


      • #4
        Bueler?! Anybody? I'd put in a support ticket but I'm expired until I buy the new version....

        Comment


        • #5
          You need to upgrade to vBulletin 3.8.5 or higher.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Originally posted by Wayne Luke View Post
            You need to upgrade to vBulletin 3.8.5 or higher.
            I'm sending you a PM now.

            Hmmm, can't figure out how haha. What are the chances VB will provide me with a copy of 3.8.5 for me to do my restore and roll with until I can purchase a 5 license next month? I have an owned 3.7.2 license now.

            EDIT: I got this resolved by having my host downgrade the version of PHP that I'm running until I can upgrade to v5.

            Thanks!
            anguilla1980
            Senior Member
            Last edited by anguilla1980; Wed 9 Oct '13, 11:51am.

            Comment


            • #7
              Originally posted by 92GTA View Post

              I'm sending you a PM now.

              Hmmm, can't figure out how haha. What are the chances VB will provide me with a copy of 3.8.5 for me to do my restore and roll with until I can purchase a 5 license next month? I have an owned 3.7.2 license now.

              EDIT: I got this resolved by having my host downgrade the version of PHP that I'm running until I can upgrade to v5.

              Thanks!
              You might want to consider upgrading to 3.8.7 PL3, instead.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X