Announcement

Collapse
No announcement yet.

vBulletin 3.8.8 / 3.8.9 Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mark.B
    replied
    Please could you log this in the tracker so it can be investigated? Link is up at the top.

    Leave a comment:


  • wmtech
    replied
    The problem only happens if a post is edited using the AJAX direct edit method. If you edit using the full editpost page, it works as it should.

    It seems that e.g. the character Ä (HTML Ä ) is converted to %u00c4 when submitting the edit in qe and returned as an invisible character when the post is reloaded. Same with all other special charaters in the edited post.

    Yes, we use latest beta 3.

    Deactivating the direct edit and quick reply features is a temporary solution.

    Leave a comment:


  • Paul M
    replied
    I can post the following ;

    Test : æ, ā, ǣ, ō, ē, ū, ȳ, x

    I can also edit it ok, both using normal and ajax, standard and wysiwyg editors.

    Is there something Im missing ?

    Are you actually referrings to Beta 3, or an older versions (an issue with ajax and some chars in Beta 1 was fixed in Beta 2).

    Have you logged any of this in Jira ?

    Leave a comment:


  • wmtech
    replied
    When you edit a post in 3,8,9 beta all special characters (such as german umlauts) of the post get removed. Happens only with edits. Posting new posts works without problems.

    Leave a comment:


  • Paul M
    replied
    There is no such report, so what are you referring to ?

    Leave a comment:


  • wmtech
    replied
    If you run a non-english forum 3.8.9 beta 3 is not for you. You'll run into problems with special characters when editing posts.

    Leave a comment:


  • Frieda MSweb
    replied
    Ok, thanks again . The picture is getting clear . And yes, I díd update quite some files. I'll consider the pros and cons!

    Leave a comment:


  • Paul M
    replied
    Originally posted by Frieda MSweb View Post
    So I'm afraid I have to ask the question again: Can i run 3.8.8 with PHP 5.5?
    I already answered this, the answer has not magically changed.

    I dont see why you think upgrading from 3.8.8 to 3.8.9 is a lot of work - unless you have lots of modified core files (in which case why ?).

    Upload files, run upgrader. Done.

    Leave a comment:


  • Mark.B
    replied
    If you're running php 5.5. the only supported solution is to upgrade to 3.8.9. That's not to say you might get away with something else, but if anything goes wrong, our support will be limited to "upgrade to 3.8.9".

    Unless you've modified a lot of files, it isn't much work at all.

    Leave a comment:


  • Frieda MSweb
    replied
    And what about this then?

    I'm already using mysqli, and the the preg_replace Deprecated messages I can handle.

    So... do I really need 3.8.9? Because of what change from PHP 5.4 to 5.5? It's quite a lot of work to update from 3.8.8 to 3.8.9, so I'd be really with the right info.

    Originally posted by Paul M View Post

    php 5.5 deprecated mysql (for mysqli) and also the /e option in preg_replace.

    vB 3.8.8 was actually modified for the first change (if you have mysql set, and are running php5.5+, it will silently switch to using mysqli anyway).

    As far as preg_replace is concerned, all 5.5 does is generate DEPRECATED warnings, if you disable php error reporting, you will probably be able to run ok.

    Leave a comment:


  • Mark.B
    replied
    No. You need 3.8.9 for PHP 5.5.

    Leave a comment:


  • Frieda MSweb
    replied
    Just by today I found the 3.8.9 beta 3 version. I did a quick (very quick!) compare with the 3.8.8, and found far more changes than just the preg_replace. So I'm afraid I have to ask the question again: Can i run 3.8.8 with PHP 5.5?

    Leave a comment:


  • Frieda MSweb
    replied
    Thanks Paul. That's a great relief. And nice that at least sómeone is able to provide us with the suitable info .

    Leave a comment:


  • Paul M
    replied
    Originally posted by Frieda MSweb View Post


    I wonder... in what way is 3.8.8 not compatible with php 5.5? I'm gonna run into big problems if this is true.
    php 5.5 deprecated mysql (for mysqli) and also the /e option in preg_replace.

    vB 3.8.8 was actually modified for the first change (if you have mysql set, and are running php5.5+, it will silently switch to using mysqli anyway).

    As far as preg_replace is concerned, all 5.5 does is generate DEPRECATED warnings, if you disable php error reporting, you will probably be able to run ok.


    JFYI, vB4 is currently being updated for php 5.5 (updating all the affected preg_replace calls). After that I hope to migrate the changes to vB3.

    Leave a comment:


  • Mark.B
    replied
    Originally posted by Daryn View Post
    I am getting the version notice too, but since there are no major changes other than PHP 5.4 compatability and my license is considered inactive, I'm not upgrading. So, I'm wondering if there's a way to dismiss the notification so I don't have to keep seeing it?
    No, there's no way to do this.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X