Announcement

Collapse
No announcement yet.

Can't get email working again after server move

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get email working again after server move

    Moved from one Centos server to another. New server is brand-new install of Centos 6.3 64-bit. Forum is up and running, but only problem is that email notifications aren't working. When I go to the email diagnostic in the control panel, it always fails with the following error:

    The mailing function returned an error while trying to send the mail.
    The following errors were outputted by PHP when attempting to send mail:


    Warning: fsockopen(): unable to connect to tcp://localhost:25 (Permission denied) in [path]/includes/class_mail.php on line 641

    Warning: Unable to connect to SMTP server in [path]/includes/class_mail.php on line 607

    This happens no matter what settings I have in the SMTP settings. On the old server, the settings were completely vanilla (localhost, 25, and no auth). I tried those settings, along with every other combination, with no luck. When I am in Webmin in the server, I can send email directly from that interface, so the mailserver itself is functional:


    This is a test message from Webmin, sent with the settings :





    Mail server: Mail server: Postfix


    Sent via: Local mail server


    SMTP login: None


    SMTP authentication: Default

    I've looked through the php.ini files on both sides, and can find no differences. I loaded up the old php.ini onto the new server just to see if that would work, and it didn't help. I reloaded the class_mail.php file just in case it was corrupt in some way, but that didn't fix it either. Thanks for any potential suggestions, as my forum is dead in the water until I fix this (no new users can sign up). Is there any other logfile where I can see more details about what exactly is going wrong?
    www.montgomerybikers.com / www.ninjette.org / www.cal24.com

  • #2
    Here is what it looks like when I telnet to port 25 on either localhost or 127.0.0.1. It does look like it's doing something weird for localhost, but not for the numerical. Regardless, webmin can send email through it, so it still seems somewhat functional.


    www.montgomerybikers.com / www.ninjette.org / www.cal24.com

    Comment


    • #3
      I just reloaded the entire set of 3.8.7 PL3 files, and went through the upgrade script. I think before it was 3.8.7, but I had just uploaded the patches. The Diagnostic now show no files of difference versions. I disabled all plug-ins, but there is still no change with this email issue.
      www.montgomerybikers.com / www.ninjette.org / www.cal24.com

      Comment


      • #5
        I found the fix. It failed on smtp or php, but here's why:

        http://www.vbulletin.com/forum/forum...417cdc5d07876b

        Now I just need to make sure that it keeps that setting through reboots, but I'm on the right track.
        www.montgomerybikers.com / www.ninjette.org / www.cal24.com

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X