Announcement

Collapse
No announcement yet.

Quick Style Chooser Not Saving For Guests

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick Style Chooser Not Saving For Guests

    There is a option to change the style of the page from "Hero" to "Villain", "Hero" being the default style. However, if you use the quick style chooser to change the style to "Villain" and then move to a different page, the next page will default to "Hero". This only happens when you are not logged in and are in guest mode. It works just fine for logged in users.

    How would I go about fixing this so that even guests get a sticky style?

    Thanks for your help.

  • #2
    Did you change your cookies settings? What is the link to your forums?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Cookies haven't changed. Apparently this has never worked as expected. You won't be able to login unless you have a game account. Here's the link: http://boards.cityofheroes.com/

      Comment


      • #4
        It works here and on other forums.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

        Admin CP -> Plugins & Products -> Manage Products -> Disable

        Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

        Admin CP -> Plugins & Products -> Plugin Manager

        You must do BOTH of those steps in order to disable all non vBulletin Modifications.

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

        Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          That seems pretty verbose. Is there anyway I can just take what's set in the cookie and run a hook to tack the styleid in the cookie to all the links on the forums?

          Comment


          • #6
            Originally posted by stevieAnn-chambe View Post
            That seems pretty verbose. Is there anyway I can just take what's set in the cookie and run a hook to tack the styleid in the cookie to all the links on the forums?
            That would be skirting round the problem somewhat, and plus you'd need to ask about that on www.vbulletin.org as it involved modifying the code. If you have cookies not persisting for styleids, then potentially you may have cookies not persisting elsewhere on the site that you may not yet know about.

            Steve's response, while seeming verbose, is the standard response in such cases, because there is no issue with the feature in question - therefore it's something you've changed that is causing this. What Steve is asking you to do should help to identify what this is and then get it fixed for you - since as has been stated, it works on everyone else's sites.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.4 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Hello


              I do not know what is happening and why we disappeared down "Quick Style Chooser" for quick change skins,can you help me for solve this problem thanks

              here is link yo my board http://www.sat-planet.net/index2.php

              Comment


              • #8
                I did try disabling hooks/plugins the problem is still there. We just moved to another hosting. Could there be something with server configuration that is effecting this. I just don't understand why would the problem would only effect skin chooser

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X