Announcement

Collapse
No announcement yet.

External links are made to look like part of my site

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • External links are made to look like part of my site

    Hi all,

    I am having a rather strange issue with external links posted in my threads.

    I will kindly ask if anyone had the same issue with external links ?
    Here's my problem.

    When a forum user posts a link with no http:// and with no www (e.g. just vbulletin.com ), then this link will become like a part of my site in the shape of http://www.mysite.com/forum/vbulletin.com which is obviously reported as a 404.

    Here's an example link to see it in action
    http://www.insurance-forums.net/forum/insurance-websites/has-anyone-built-facebook-page-their-business-t31088.html#post388403

    See the facebook and the other URL how they're linked

    There are no problems when links are, for example posted as www.vbulletin.com or http://www.vbulletin.com or any other shape, it's just that when there's no prefix (http and www) the links are rewritten wrongly as above.

    I have vBSEO so I completely disabled it, I disabled hooks, renamed htaccess and this behaviour keeps happening.


    I hope someone can help me on this strange issue if ever encountered something similar.

    Thanks.
    Val.

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      so if a user just post vbulletin.com, it'll make it a hyperlink?
      That's not a default setting.
      if they post [url ]vbulletin.com[ /url] (remove the spaces)
      it should add the http:// for you
      -- Web Developer for hire
      ---Online Marketing Tools and Articles

      Comment


      • #4
        Thanks for generic answer Trevor. I disabled all mods by switching off the Plugin Hooks, disabled vBSEO, removed .htaccess and the issue was still up there. The suspect File versions didn't bring up anything odd and from server logs there's no suspicious activity as well.

        Brandon, this happens only when users enter vbulletin.com (or similar link without http:// nor without www.) in hyperlink pop-up. See this screenshot



        Just by writing vbulletin.com, it isn't making it into a link, but the above case from screen is making links wrong.

        Thanks,
        Val.

        Comment


        • #5
          A quick update:

          What's even more strange is that following steps as in the screenshot, returns the
          correct URL in Google Chrome, but fails to do so in Firefox 4 and IE8

          Here are my results from three browsers, on my site (vbulletin link used as example here)

          FF 4
          vbulletin.com

          Chrome:
          vbulletin.com

          IE8:
          vbulletin.com

          As you see only Chrome returns the correct URL.
          Last edited by valdet; Tue 17th May '11, 5:14am.

          Comment


          • #6
            vbulletin.com

            does it work fine here?

            yup..

            sorry man, I don't know what to tell ya
            it seems like it's a mod conflict?
            -- Web Developer for hire
            ---Online Marketing Tools and Articles

            Comment


            • #7
              Originally posted by Loco.M View Post
              vbulletin.com

              does it work fine here?

              yup..
              Yup, but this site is running vb 4.1.4 and valdet is asking about vb 3.8.

              I think the examples show that in v3.8 the "create link" editor function didn't work quite the same on all browsers. But I kind of doubt anyone's going to work on the old editor js.

              Comment


              • #8
                Brandon, it cannot be a mod problem, because as I said above, I disabled the plugin/hooks system and the problem was still there under circumstance as in screenshot.

                Originally posted by klh View Post
                Yup, but this site is running vb 4.1.4 and valdet is asking about vb 3.8.

                I think the examples show that in v3.8 the &quot;create link&quot; editor function didn't work quite the same on all browsers. But I kind of doubt anyone's going to work on the old editor js.
                You're right. This problem is for vB 3.x, hence this thread is in 3.x forums.
                I posted how the links are returned when inserting them from different browsers.

                Maybe this is just a vB 3.x bug that wasn't addressed.

                Comment


                • #9
                  It's not a 3.x bug, I've been placing links in the editor that way for years.
                  I know you said you disabled the plugins, but it could still be something that isn't default.
                  Is this on the default style, have you tried what Trevor posted in his reply?
                  Can you reproduce it the bug on a fresh 3.x install?
                  -- Web Developer for hire
                  ---Online Marketing Tools and Articles

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X