Announcement

Collapse
No announcement yet.

How to troubleshoot plugin errors?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Paul M
    replied
    Try re-installing one of them, it could be the cache of the code in the datastore, and re-installing one will rebuild the datastore cache.

    Leave a comment:


  • IBxAnders
    replied
    Originally posted by christon26 View Post
    Hi Anders, I did disable all the products and the warnings were all still there. I am presently in the plugin manager and have disabled all the hook locations and one by one am re -enabling them. I have so far found that any plugin that calls one of these two hooks is failing:

    Warning: Failure in [path]/global.php on line 1091 {global_setup_complete}
    Warning: Failure in [path]/index.php on line 596 {forumhome_complete}

    I am also reuploading the forum files to make sure none got corrupted somehow, I've had 4 plugins so far cause the warnings when I re-enable them....would this still be a plugin issue or something else causing this?
    If you disabled all products and had the warnings; then its a different issue and you might have to check with your host.

    Leave a comment:


  • christon26
    replied
    Hi Anders, I did disable all the products and the warnings were all still there. I am presently in the plugin manager and have disabled all the hook locations and one by one am re -enabling them. I have so far found that any plugin that calls one of these two hooks is failing:

    Warning: Failure in [path]/global.php on line 1091 {global_setup_complete}
    Warning: Failure in [path]/index.php on line 596 {forumhome_complete}

    I am also reuploading the forum files to make sure none got corrupted somehow, I've had 4 plugins so far cause the warnings when I re-enable them....would this still be a plugin issue or something else causing this?

    Leave a comment:


  • IBxAnders
    replied
    Disable all products; turn them all off; then turn each one on, one by one, to see the exact product causing the issue.

    Leave a comment:


  • christon26
    started a topic How to troubleshoot plugin errors?

    How to troubleshoot plugin errors?

    Hi, I am having some problems with my forum, I woke up this morning to find my forum covered in these errors:

    Warning: Failure in [path]/global.php on line 607
    Please contact support about

    Warning: Failure in [path]/global.php on line 1091
    Please contact support about

    Warning: Failure in [path]/index.php on line 67
    Please contact support about

    Warning: Failure in [path]/includes/functions_forumlist.php on line 393
    Please contact support about
    Lots more than that lol

    So I disabled hooks globally (all those lines are lines calling hooks) which took the warnings away. I then disabled all my plugins in the Product Manager, re-enabled the hooks in config and the warnings are still there....so I'm kind of lost lol

    I wasn't installing products when the warnings popped up, nor was I even in admin (I am the only admin), they just appeared overnight, seemingly out of nowhere. Given that disabling the products themselves didn't remove the warnings, what is my next step?

    Thanx in advance
    Lissa
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X