Announcement

Collapse
No announcement yet.

Users unable to upload custom avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Users unable to upload custom avatars

    They report they are getting "invalid file" errors. Can anybody help?

    We're running v. 3.8.5
    Cult Movie Forums

  • #2
    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Now enabled:

      http://www.pre-cert.co.uk/forum/
      Cult Movie Forums

      Comment


      • #4
        You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

        /var/www/vhosts/pre-cert.co.uk/httpdocs/tmp

        Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

        Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes


        Also the php.ini setting for 'upload_tmp_dir' is empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X