Announcement

Collapse
No announcement yet.

Having troubles reinstalling Vbulletin 3.8.7

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having troubles reinstalling Vbulletin 3.8.7

    Hello,

    I am new to vbulletin and forum software. I recently downloaded Vbulletin 3.8.7 and installed it through siteground.com and cpanel. I followed all the instructions and even watched tutorials on the step by step processes to install it before I went ahead and did it myself.
    With that said, I uploaded it and had the forum running, but decided to do some testing by try using addons such as iTrader and some facebook applications and succeeded. I did however rushed with one of the mods and screwed up royally. To shorten the story, I decided to start all over again. I deleted the user and the database, and erased all the files in the Cpanel file manager.
    However, I tried to do this process all over from scratch again, but am coming up with this:
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

    I've looked all over the place for an answer for this and came up nil. I've seen people with this same probleb, but have been resolved by putting in the correct information. I did this the exact way I did it the first time too.

    Here is the email that I get for the database error:

    Code:
    Database error in vBulletin :
     
    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Lost connection to MySQL server at 'reading initial communication packet', system error: 0
    /home/maplele4/public_html/forum/includes/class_core.php on line 311
     
    MySQL Error : 
    Error Number : 
    Request Date : Friday, April 29th 2011 @ 01:18:37 PM
    Error Date : Friday, April 29th 2011 @ 01:18:37 PM
    Script : http://www.mapleleaffans.com/forum/forumdisplay.php?f=13
    Referrer : 
    IP Address : xx.xxx.xx.xx
    Username : 
    Classname : vB_Database
    MySQL Version :

    Any help would be very much appreciated, Thank you!
    Paul
    https://www.vbulletin.com/forum/cust...ic337140_4.gif

  • #2
    I forgot to add, after removing vbulletin completely, I reinstalled it on another another domain. It failed to work there, so I deleted it there, and tried it back on the first domain. Not sure if that has anything to do with it, but thought I'd mention it...
    Paul
    https://www.vbulletin.com/forum/cust...ic337140_4.gif

    Comment


    • #3
      Originally posted by mapleleaffans View Post
      However, I tried to do this process all over from scratch again, but am coming up with this:
      The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

      ...

      Any help would be very much appreciated, Thank you!
      Check again and again your config.php file.
      Something is wrong there.
      The user does not have permission to connect to the server.


      vB5 is unequivocally the best forum software, but not yet...

      Comment


      • #4
        Originally posted by beishe8 View Post
        Check again and again your config.php file.
        Something is wrong there.
        The user does not have permission to connect to the server.
        Hmm.. wonder if it has something to do with the host I am using (siteground.com). Could I be blocked from the server for some reason? I have done this several times and have checked and double checked my information in the config.php file and it all matches up with the MySQL database that I created as well as the username and password. I even have the correct servername and port that siteground uses. I'm lost.
        Paul
        https://www.vbulletin.com/forum/cust...ic337140_4.gif

        Comment


        • #5
          The most likely cause of the error in post #3 is that the info in your config.php file is wrong or your db user does not have full permissions to this database. Please read this for all the known causes of this error:

          http://www.vbulletin.com/forum/showthread.php?t=194542
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by mapleleaffans View Post
            and have checked and double checked my information in the config.php file and it all matches up with the MySQL database that I created as well as the username and password.
            It could be as simple as the username is mapleleaffans_mapleleaffans instead of mapleleaffans.
            mapleleaffans does not have permission to "that" database.


            vB5 is unequivocally the best forum software, but not yet...

            Comment


            • #7
              Originally posted by Steve Machol View Post
              The most likely cause of the error in post #3 is that the info in your config.php file is wrong or your db user does not have full permissions to this database. Please read this for all the known causes of this error:

              http://www.vbulletin.com/forum/showthread.php?t=194542
              Originally posted by beishe8 View Post
              It could be as simple as the username is mapleleaffans_mapleleaffans instead of mapleleaffans.
              mapleleaffans does not have permission to "that" database.
              I've checked the username and password and they match up correct. The database name is maplele4_vb3 and the username is maplele4_admin, and they match up with the config.php file. This morning I woke up to more than a dozen error reports like seen above. I filled out a support ticket at siteground. Maybe it's a server issue?
              Paul
              https://www.vbulletin.com/forum/cust...ic337140_4.gif

              Comment


              • #8
                Then you need to wait for your host. All possible causes of this problem are in the thread I linked to.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  Then you need to wait for your host. All possible causes of this problem are in the thread I linked to.
                  Thanks for your help, Steve and beishe8, much appreciated. I sent a support ticket out over there and see if it's on thier end. If not, I will look into the possibilites in that thread you posted, Steve.
                  Paul
                  https://www.vbulletin.com/forum/cust...ic337140_4.gif

                  Comment


                  • #10
                    Just a heads up, I did get this resolved. Siteground made a database for me, and redid all the info and it works fine! I am so glad to have vbulletin back! Thank you guys for pointing me in the right direction! It is very much appreciated!

                    Paul
                    Paul
                    https://www.vbulletin.com/forum/cust...ic337140_4.gif

                    Comment


                    • #11
                      Originally posted by mapleleaffans View Post
                      Just a heads up, I did get this resolved.
                      Congrats to your new forum,Paul!
                      Start posting!


                      vB5 is unequivocally the best forum software, but not yet...

                      Comment


                      • #12
                        Originally posted by beishe8 View Post
                        Congrats to your new forum,Paul!
                        Start posting!
                        Thank you beishe8! I got lots of work ahead of me, but not complaining. I've used other applications like phpbb, AEF and others, and I must say, VBulletin is the best, hands down. What a great interface! So many options and ways to set up things! I love it!
                        Paul
                        https://www.vbulletin.com/forum/cust...ic337140_4.gif

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X