Announcement

Collapse
No announcement yet.

Advanced edit (WYSIWYG)and delete functions Not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Advanced edit (WYSIWYG)and delete functions Not working

    I don't know what happened but My WYSIWYG editor and functions like delete thread are no longer working on my site. I can delete it if I check the box and use Admin functions to do so but not through the "Edit Thread" area. I'm running 3.8.4 PL1 and have checked permissions, rebuilt tables, updated counters and it still doesn't work. I can edit If I set the editors to "Standard" in AdminCP but when set to "WYSIWYG and standard" when I click on the "Advanced" edit button, nothing happens, same as if I click the delete thread button down at bottom, nothing happens. I'm running Windows XP Pro SP3 & IE 8, No Firewall. Site is run on a Linux server.

    http://www.united4freedom.net

    Thank you...

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products:

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Still no luck Steve

      Thank you Steve for your quick reply, Ok I've tried everything you suggested in the Order in which you suggested them and still have the same problem. When I run the Diags, I get a lot of files listed that indicate they are not vB files ("File not recognized as part of vBulletin") I recoginize that these are files I created or Files for installed Hacks. I created a new style and still same trouble. Cleared Browser of ALL history, files, cookies etc... everything I could clear.
      I do see some files in there from Face book connect, which I have uninstalled but it appears the physical files are still there. I'm gonna try deleting all of them and see if that helps...


      Ok that didn't help.... here's a web Browser error I get at bottom of page when I click the "Go Advanced" button

      "Webpage error details
      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)
      Timestamp: Thu, 21 Apr 2011 17:13:24 UTC

      Message: 'document.body.appendChild(...)' is null or not an object
      Line: 11
      Char: 9392
      Code: 0
      URI: http://www.united4freedom.net/client...lobal.js?v=384

      I've reloaded the vbulletin_global.JS file from original install files again, but same problem...
      I'm stumped...Hope your Not... LOL

      Thank you
      Tom

      Comment


      • #4
        I get this error from your forum link:

        Fatal error: Call to undefined function print_portal_output() in /home/supersku/public_html/cmps_index.php on line 46

        And that is due to the vBAdvanced add-on.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          yeah My site is set to goto CMPS_index.php by default, just use index.php to access the Bulletin board I have disabled the CMPS as you suggested...

          Comment


          • #6
            You are running 3.8.4. The next step is to upgrade to 3.8.7.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I have an ownership license, I don't believe I'm eligable right now for an upgrade... I have seen the Notice in my adminCP , but when I go to vBulletin site, 3.7 is not an available option for me and I don't have the cash to invest right now in any additional software. I really love to get to 4.x if finances would allow it but times are tough right now in the USA. I appreciate your help Steve, but an upgracde at this time is just not financally possible, wish it was...

              Tom

              Well it appears that I'm unable to renew my license for 3.8.x even if I wanted to, Upgrades are the only available option, so I guess 3.8.7 just floats around in a void for us here...
              Last edited by xTerMn8r; Thu 21st Apr '11, 11:30am. Reason: tried to renew?

              Comment


              • #8
                Ok here's the latest, If I disable the Quick edit, and Quick reply in Admincp - vbulletin options - message posting and editting options, and then click the edit option in the thread/Post, I now get at the top, delete options, below that I have a Full WYSIWYG editor, and below that auto embed, close and stick options. I guess this will have to be my solution at this point. Don't know if this will help you isolate the issue... BTW it doesn't matter what I set the Editor interface options too now with the quick edits off, standard or WYSIWYG I still get the WYSIWYG editor when I click the edit button, and thats Ok with me, but just thought I'd mention that.

                Thanks again,
                Tom

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X