Announcement

Collapse
No announcement yet.

Templates Not Saving

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Templates Not Saving

    I've noticed recently that when i edit a template, it dosnt show up on the site.

    When ive edited the template i checked in the admin cp & i can see that my new edit has saved, but it dosnt show up on my site.

    Im using Vboptimise, i've flushed the catche & the catche for my browser, but it still dont show.

    Is there anyway of saving templates outside of the acp, like via ftp on the server? but i dont know where the template files are saved.

  • #2
    No, there is no option to do this.

    Are you sure you are looking at the correct style? If so, this problem is almost certainly due to a modification.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Isnt there a easyer way m8, i've got a lot of mods & a custom skin & i was hoping it didnt have to do all that.

      I have moved host a few months back, i dunno if that got anything to do with it.

      Comment


      • #4
        Since this is either a problem with a modification or an issue with the server, this is a necessary step to troubleshoot the problem.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Do you think i could get it to save if i dissable all mods, then save the template, then enable the mods.

          Im just tring to add my Google Analytics tracking code to the header.

          Comment


          • #6
            That is certainly worth a try.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Dj Smuggla View Post
              Do you think i could get it to save if i dissable all mods, then save the template, then enable the mods.

              Im just tring to add my Google Analytics tracking code to the header.
              It needs to go into the HEADINCLUDE template, not header.
              Put <vb:literal> around your code </vb:literal>

              Comment


              • #8
                Im using vb 3.8.6 & just to confirm its the Google Analytics tracking code. It says to put it above the </head> tag & i saw that in the header template.

                Comment


                • #9
                  The <vb:literal> tags are for vB4. But your code needs to go into the headinclude template regardless.

                  Comment


                  • #10
                    I've managed to get around it.
                    I downloaded my style (with the new edits in the templates) then installed it again & now i can see the edits on the site...

                    Ive set the new style as default, but how do i make all the members use the new style i just installed instead of the old one?

                    I want to remove to old one & just keep this new one i just installed...

                    Comment


                    • #11
                      Delete the old one and set the new one as the default in AdminCP > Settings > Options > Style & Language Options
                      Vote for:

                      - *Admin Settable Paid Subscription Reminder Timeframe*
                      -
                      *PM - Add ability to reply to originator only*
                      - Add Admin ability to auto-subscribe users to specific channel(s)
                      - Highlight the correct navigation tab when you are on a custom page
                      - "Quick Route" Interface...
                      - Allow to use custom icons for individual forums

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X