No announcement yet.

Unable to add cookies, header already sent.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to add cookies, header already sent.

    Hi There,

    I am moving my forum to another server so I migrated all data and ready to replace new name servers.

    My my forum is running on an IP for testing purpose and suddenly I got an error on my new server its

    Unable to add cookies, header already sent.
    File: /home/funmasti/public_html/admincp/index.php
    Line: 1

    and on showthread urls i found this

    I disabled plugin using this define('DISABLE_HOOKS', true);

    Still no luck

  • #2
    Problem solved I got a hack attack, those good guys modified my index.php and showthread.php file, everything is recovered now
    Last edited by funmasti; Tue 22 Mar '11, 10:21pm.


    • #3
      I'm having this problem now and I'm not sure how to go about fixing it.

      Unable to add cookies, header already sent.
      File: /home/content/74/7532774/html/forumdisplay.php(942) : eval()'d code
      Line: 36

      Everything was running fine. I just finished importing all of the (thousands) of sub-forums, etc., and then I log in this morning and get this. I didn't make a back-up (yet), not sure how to go about fixing this.


      * I'm in vB 4.1.2 by the way, I'll post it there.


      • #4
        That eval() error is form a modification.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

        Admin CP -> Plugins & Products -> Manage Products -> Disable

        Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

        Admin CP -> Plugins & Products -> Plugin Manager

        You must do BOTH of those steps in order to disable all non vBulletin Modifications.

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography

        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.