Announcement

Collapse
No announcement yet.

vBulletin 3.8 & Issue Handling Javascript in IE 8

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 3.8 & Issue Handling Javascript in IE 8

    Hi there, I'm trying to use SWFObject specifically to embed audio files on my message board using JWPlayer. When I embed the javascript in the posts, I can see the embedded music player fine in Firefox, but in IE, I cannot. Also when I check the code, IE does not show the exact code I had put in when creating the post.

    Does vBulletin and IE8 (also Google Chrome has the issue) handle javascript in a certain way that it is somehow preventing the media player from displaying correct?

    Again, Firefox displays everything fine.

  • #2
    Javascript differes slightly between browsers, also javascript is normally stripped from posts. You'd need to check the javascript works fine by itself outside of vBulletin first in all of the browsers.

    Comment


    • #3
      Originally posted by Zachery View Post
      Javascript differes slightly between browsers, also javascript is normally stripped from posts. You'd need to check the javascript works fine by itself outside of vBulletin first in all of the browsers.
      Hi Zack, I tried doing it outside the browser in a standard HTML file and it works fine in all browsers. This is what is supposed to appear:

      http://nokturnalist.com/Test.html

      When I put that code into vBulletin, it works in Firefox, but not IE or Chrome. The ultimate goal is to embed this media player in posts.

      I also tried to embed the player using HTML instead of javascript but vBulletin isn't handling that right either. I'm going to try and do this using the default vBulletin style. Someone had a similar issue here that I posted on:

      http://www.vbulletin.com/forum/showt...oblems-with-IE

      Let me know if you have any ideas. I am also going to renew my subscription so I can update to 3.8.7, though not sure if doing that will help this issue. Thanks for the help!

      Comment


      • #4
        I know this is a super old post and I see there was never a cure posted. I am having the same problem with a fresh install of VB 3.8.8. I have searched high and low for a cure with no luck at all. So sad to see no help was given here so maybe bringing it back alive someone over the last 4 years has found the answer to this problem?

        Comment


        • Wayne Luke
          Wayne Luke commented
          Editing a comment
          You should upgrade from IE 8.

      • #5
        Originally posted by Crossbow View Post
        I know this is a super old post and I see there was never a cure posted. I am having the same problem with a fresh install of VB 3.8.8. I have searched high and low for a cure with no luck at all. So sad to see no help was given here so maybe bringing it back alive someone over the last 4 years has found the answer to this problem?
        Please start your own thread, and provide as much information as possible.
        My Mods also available at OzzModz.com

        New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders!
        Stop Spam Now The era of Big Spam is over.

        Vote to bring back hooks in vB5, http://tracker.vbulletin.com/browse/VBV-10333

        Comment


        • #6
          Good old ozzy47 strikes again.

          Comment


          • #7
            IE8 isnt supported. Additionally for questions on code modifications, you need to ask at vbulletin.org.
            Baby, I was born this way

            Comment

            Related Topics

            Collapse

            Working...
            X