Announcement

Collapse
No announcement yet.

Admin Are Now Registered Users

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Admin Are Now Registered Users

    Good afternoon,

    I don't know how it occurred but all 4 admin on my site have reverted to Registered users and of course that means via the ACP none of us can change the status back.

    We have 2 Supermods and their status is fine unfortunately they cannot access the ACP because of the permissions.

    How do gain access to the ACP via the FTP ?

    I read somwehere about uploading the 'tool.php' from the do_not_upload folder from my vBulletin zip-file to my admincp directory, and then running it to reset the admin access for my username.

    I'm a novice at this kind of thing and any help would be truly appreciated.

    Thanks.

  • #2
    If you have access to the config.php, add a trusted user account to your 'Super Administrator' entry.

    Example:
    Code:
        //    ****** SUPER ADMINISTRATORS ******
        //    The users specified below will have permission to access the administrator permissions
        //    page, which controls the permissions of other administrators
    $config['SpecialUsers']['superadministrators'] = '1';
    In this line:

    $config['SpecialUsers']['superadministrators'] = '1';

    Replace or add a user ID (number) that you would like to use to access the AdminCP. Remove this later if you don't want that user to remain as a 'Super Administrator'.

    ---OR---

    Upload tools.php to your admincp folder, run that from your browser (http://yourforum.url/admincp/tools.php). After inside, you can upgrade the access rights of a selected user. Remove tools.php from your server immediately after you add the access rights.
    To be updated...

    Comment


    • #3
      Thanks a bunch ENF, the 2nd option worked a treat !

      I'd already checked the $config file and all the ID numbers for SpecialUsers were correctly inputted, still it didn't work until I chose the 2nd option.

      I was in the Admin CP doing persmissions for a new usergroup when this happened, must have been a glitch as I certainly didn't do anywhere near Admin (who are listed top) and Moderated which was my new usergroup.

      Thanks a million again.

      Comment


      • #4
        Originally posted by Braders View Post
        Thanks a bunch ENF, the 2nd option worked a treat !

        I'd already checked the $config file and all the ID numbers for SpecialUsers were correctly inputted, still it didn't work until I chose the 2nd option.

        I was in the Admin CP doing persmissions for a new usergroup when this happened, must have been a glitch as I certainly didn't do anywhere near Admin (who are listed top) and Moderated which was my new usergroup.

        Thanks a million again.
        Glad you got it resolved.
        To be updated...

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X