Announcement

Collapse
No announcement yet.

RSS feed problem: no thread ID in URLs results in "no thread specified" error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RSS feed problem: no thread ID in URLs results in "no thread specified" error

    Hello -

    No luck finding this specific problem searching the forum first...

    A user reported today that clicking an RSS link to our forum resulted in the "no thread specified" error.

    Looking at the URLs in our feed, it appears none of them have any thread or post ID info appended to them. They all simply point to "showthread.php"

    Any suggestions for investigating this would be appreciated.

    Thanks.
    Last edited by vbem2; Wed 5th Jan '11, 7:13pm.

  • #2
    That is almost certainly from vBSEO. Try disabling it completely, including all it's redirects.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Aha!

      vBSEO was upgraded earlier this week. Thanks for the pointer - will look into it.

      Comment


      • #4
        No luck.

        I disabled vBSEO and vBSEO Sitemap Generator products via the vB ACP, visited http://www.ecomodder.com/forum/external.php?type=rss2 and the problem persists.

        Comment


        • #5
          Re-reading your instructions, not sure how to disable "all it's redirects", if that's not the same as disabling the products via the ACP.

          Comment


          • #6
            You also have to remove the .htaccess redirects for vBSEO.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thank you. I was able to fix the problem by disabling the vBSEO products and commenting out all the redirects in the /forum .htaccess file.

              I will contact vBSEO to resolve this.

              Appreciate the guidance!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X