Announcement

Collapse
No announcement yet.

Registered members can see soft-deleted threads

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Registered members can see soft-deleted threads

    Hi,
    Sometimes I soft-delete thread to hide it, but then I noticed that registered members can see there are deleted threads in forums, anyway they can't see what it contains.
    How can I ban registered members from knowing that there are some deleted threads in forum?

    Thanks

  • #2
    There is an option in the user group settings, located in the "Forum Viewing Permissions" area: "Can see deletion notices" (Yes/No)

    Help text shows:
    Originally posted by Help Text
    When an admin or mod deletes a thread they are given the option to "soft delete" or "physically delete." When a thread is "soft deleted" a deletion notice is left in its place in the forum thread listing. This permission determines whether or not members of this group can see those deletion notices.
    Check this setting to achieve your desired result.

    AdminCP -> User Groups -> User Group Manager -> [Edit Appropriate User Groups]
    To be updated...

    Comment


    • #3
      Yes, I set Can see deletion notices to No, but still registered members can see deleted threads.

      Comment


      • #4
        Originally posted by Penicillin View Post
        Yes, I set Can see deletion notices to No, but still registered members can see deleted threads.
        Do you have any mods that could impact this?

        Also, those registered users, they are not members of more than one group? Potentially having conflicting rights?

        I've gone over the settings again and as far as I can tell or remember, this is the only place to set it for regular users.
        To be updated...

        Comment


        • #5
          Originally posted by ENF View Post
          Do you have any mods that could impact this?

          Also, those registered users, they are not members of more than one group? Potentially having conflicting rights?

          I've gone over the settings again and as far as I can tell or remember, this is the only place to set it for regular users.
          Hi,
          I don't think I have a mod could impact this.
          All registered users listed in one group (Registered Users).

          Comment


          • #6
            I cannot duplucate this with the correct permissions and on an unmodified vB.

            To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

            [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

            Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

            Admin CP -> Plugins & Products -> Manage Products -> Disable

            Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

            Admin CP -> Plugins & Products -> Plugin Manager

            You must do BOTH of those steps in order to disable all non vBulletin Modifications.

            Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

            Do you have the same problem?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              I cannot duplucate this with the correct permissions and on an unmodified vB.

              To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

              Admin CP -> Plugins & Products -> Manage Products -> Disable

              Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

              Admin CP -> Plugins & Products -> Plugin Manager

              You must do BOTH of those steps in order to disable all non vBulletin Modifications.

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

              Do you have the same problem?
              I did all steps, I disabled all plugs-in and installed a fresh style, problem persists.

              Comment


              • #8
                Unfortunately you do not have access to ticket support. What is the URL of your forums?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  Unfortunately you do not have access to ticket support. What is the URL of your forums?
                  I have an access to ticket support, I'm a licensed member.
                  My forum URL is www.expenglish.com/vb

                  Comment


                  • #10
                    Actually you have a vB4 Forum license that is more than 30 days old and you are not eligible for ticket support.

                    I did look at your site and it is highly customized though. I still believe this problem is due to one of your modifications.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol View Post
                      Actually you have a vB4 Forum license that is more than 30 days old and you are not eligible for ticket support.

                      I did look at your site and it is highly customized though. I still believe this problem is due to one of your modifications.
                      I disabled all modifications, not solved.
                      I have another domain expenglish.net contains vB forum (for testing purpose only, not for public), should I PM you admin username and password to try it out?

                      Comment


                      • #12
                        Your site is still highly modded. Please follow the instructions in post #6.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by Steve Machol View Post
                          Your site is still highly modded. Please follow the instructions in post #6.
                          I re-disabled all modifications, please follow this link:
                          http://www.expenglish.net/vb/forumdi...?f=29&langid=1

                          Log-in using this information:
                          Username: Steve Machol
                          Password: 123456

                          You will see there are deleted threads visible.

                          Comment


                          • #14
                            I sdo not doubt this is happening. However that would not give me Admin access which I would need to troubleshoot this. And unfortunately since you do not have ticket support available to you. there is nothing I can do.

                            All I can confirm is that this is not possible with the default vB code and no add-ons, assuming your permissions are set correctly.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X