Announcement

Collapse
No announcement yet.

Style changer disappeared

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ramsesx
    replied
    This issue is still valid in 3.8.7, I found a solution here.

    Leave a comment:


  • Lynne
    replied
    As shown in your quote a couple posts above, it was already reported, so I don't understand your comments.

    Leave a comment:


  • need2fart
    replied
    If anyone ever reads this again:

    There's a bug in 3.8.6. When you enable the vB_datastore the style changer disappears. If you comment it out the vB_datastore the style changer comes back.

    I'd report this bug but I don't know how to exactly, so I'm saying it here.

    Leave a comment:


  • need2fart
    replied
    Originally posted by Qryztufre View Post
    I've been looking for a fix to this myself...

    http://tracker.vbulletin.com/browse/VBIV-9235 <- someone submitted a bug report.

    http://www.vbulletin.com/forum/showt...=style+chooser <- explains a workaround till it's fixed
    Wow. The datastore is enabled too... So the datastore makes it go kaput?

    Edit: Your right. When I comment out the datastore suddenly the style switcher is back. Does this mean I have to find a new caching system like memcache instead of the built in datastore?
    Last edited by need2fart; Wed 29th Dec '10, 1:17pm.

    Leave a comment:


  • Qryztufre
    replied
    I've been looking for a fix to this myself...

    http://tracker.vbulletin.com/browse/VBIV-9235 <- someone submitted a bug report.

    http://www.vbulletin.com/forum/showt...=style+chooser <- explains a workaround till it's fixed

    Leave a comment:


  • need2fart
    replied
    Originally posted by Lynne View Post
    Can we get a link to the site with the new default style being used (put styleid=x at the end of the url).
    Yes: http://ds-forums.com/index.php?styleid=40
    Originally you didn't need an account to change styles.

    Leave a comment:


  • Lynne
    replied
    Can we get a link to the site with the new default style being used (put styleid=x at the end of the url).

    Leave a comment:


  • need2fart
    replied
    Originally posted by Steve Machol View Post
    Then you have a modification causing this. To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Same problem. I thought it was going to work because I suspect it has to be a plugin/hook making it not appear. However this is all I see even after I applied all your steps: Click image for larger version

Name:	Untitled.png
Views:	2
Size:	10.9 KB
ID:	3681015

    I really appreciate your contribution of help Steve, would you like to checkout the problem on my board?

    Leave a comment:


  • Steve Machol
    replied
    Then you have a modification causing this. To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?

    Leave a comment:


  • need2fart
    replied
    Originally posted by Steve Machol View Post
    Also make sure that you have more than one style set at User-selectable.
    They are checked. The whole style changer at the bottom of the page is gone:\

    Leave a comment:


  • Steve Machol
    replied
    Also make sure that you have more than one style set at User-selectable.

    Leave a comment:


  • need2fart
    replied
    Originally posted by Lynne View Post
    Make sure it's on in Settings > Options > Style & Language Settings > Allow Users to Change Style
    Hmm I checked just now and it's enabled. I disabled + re-enabled and it still does not display. I created a new default vB template and it still does not display. What should I do? Is it a chmod issue?

    Leave a comment:


  • Lynne
    replied
    Make sure it's on in Settings > Options > Style & Language Settings > Allow Users to Change Style

    Leave a comment:


  • need2fart
    started a topic Style changer disappeared

    Style changer disappeared

    I cannot see the style changer anymore. It happened when I deleted a usergroup under my account when I was an undeletable user. I turned off the plugin/hook system in ACP and still the style switcher is missing. I got feedback it's also missing from other users in different usergroups.

    How do I fix it? Thanks.

Related Topics

Collapse

Working...
X