Announcement

Collapse
No announcement yet.

Upgraded from 3.7 to 3.8.6 and transferred the database over. New Users Can't Login!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • chrisarmer
    replied
    Thanks!

    Worked!

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by chrisarmer View Post
    char(3) for salt btw
    That is the problem. The salt field was updated to 30 characters in 3.8.5 and somehow you missed that step.

    Try running this query:

    ALTER TABLE user MODIFY salt CHAR(30) NOT NULL DEFAULT '';

    Leave a comment:


  • chrisarmer
    replied
    Should I run the upgrade script to see if that fixes it? Was something changed between 3.7 and 3.8 that would cause this?

    Leave a comment:


  • chrisarmer
    replied
    char(3) for salt btw

    Leave a comment:


  • chrisarmer
    replied
    It says char(32) in the password field

    Leave a comment:


  • Trevor Hannant
    replied
    If you look at the structure tab within phpMyAdmin, there will be something like 'char(30)' in the 'Type' column. What is the value in the brackets in your database?

    Leave a comment:


  • chrisarmer
    replied
    Look at the two lines I posted in the thread above. I posted them so that someone could compare them.

    (3,5,'',5,'UserA','0b3cc1dd3d51666f0ac1dead467bc14 4','2010-12-20','[email protected]',0,'','','','','','',' ',1,0,'ilikegoldyeah',2,1245097080,0,1293064475,12 93136700,1293135891,102849,5702,7190756,15,'0',2,0 ,99,0,0,42993751,'10-01-1977','1977-10-01',-1,1,'255.255.255.246',0,0,0,0,-1,16,0,'H0b',0,0,0,'',0,0,7153,113,0,0,0,0,0,0,0,0 ,NULL,NULL,NULL,1248715200,46,13,28,0,1,'',1,6413, 1,52,52,32,137,99,'',NULL,0)

    Does NOT work:

    (1465,6,'',0,'UserB','f1a3c5e722ccbb6a90bc408055f1 3dfa','2010-12-23','[email protected]',0,'','http://www.sampleb.com','','','','','',2,0,'Administrator ',0,1293143100,-1,1293143305,1293143100,0,0,0,10,4,'-6',1,0,0,0,0,45092183,'05-28-1981','1981-05-28',-1,-1,'',0,0,0,0,1,0,0,'jt4',0,0,0,'',0,1,0,0,0,0,0,0, 0,0,0,0,NULL,NULL,NULL,0,0,0,0,0,1,'',1,1,0,1,1,0, 1,0,NULL,NULL,0);

    Leave a comment:


  • Trevor Hannant
    replied
    Don't understand what you're referring to here - you are looking at your database and specifically the user table via phpMyAdmin?

    Leave a comment:


  • chrisarmer
    replied
    From the example I have above is the salt field the field right after the password with a space in between it? It looks to be different so would that be our problem? If so how do we fix it?

    Leave a comment:


  • Steve Machol
    replied
    Look at the user field in the datanbase. What is the length of the salt field?

    Leave a comment:


  • chrisarmer
    replied
    Vbulletin now sends the email but it appears that none of the passwords are being stored correctly or the users aren't being activated properly. How does vbulletin 3.8.6 interact with SALT and is there a setting somewhere that determines this? I'm at a loss as to why it doesn't work. All the files seem to be fine.

    Leave a comment:


  • Steve Machol
    replied
    1. To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?

    2. Yes, vB sends those emails. vB uses the server for it's email. Assuming you have not disabled emails in the Admin CP or in config.php, then if there are problems the issue is either with the server itself or on the receiving end.

    Please see this page for help troubleshooting email problems:

    http://www.vbulletin.com/docs/html/troubleshoot_email

    Leave a comment:


  • chrisarmer
    replied
    What other details do you want?

    Let me ask a few questions before I proceed..

    Does Vbulletin ALWAYS send emails out after creating a new user to verify them? Currently thats not happening and its not even outputting an error to exim_mainlog or exim_rejectlog. I'm using CPanel .. I have everything setup so that our domain can send / relay emails. Is there something I should check and paste you the output of?

    Also, if vbulletin doesn't always send emails what options need to be enabled and would not replying to the email cause the username and password to be locked out until the email is verified?

    Leave a comment:


  • Steve Machol
    replied
    It's not clear exactly what you did. Please provide all details.

    Leave a comment:


  • chrisarmer
    replied
    I even get this msg when I get locked out as the account holder:

    Dear UserB,

    Someone has tried to log into your account on Forums with an incorrect password at least 5 times. This person has been prevented from attempting to login to your account for the next 15 minutes.

    The person trying to log into your account had the following IP address: 255.255.255.246

    All the best,
    Forums

    Leave a comment:

Related Topics

Collapse

Working...
X