Announcement

Collapse
No announcement yet.

Upload of file failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload of file failed

    cannot upload any attachments (or avatars)
    i guess the problem started after an upgrade (don't know which one, but i have another server running 3.7, same php, mysql that has no problems)
    it is currently running vBulletin 3.8.6 Patch Level 1
    the only error message i have on the 'Manage Attachments' page is 'Upload of file failed.'
    no additional messages, nothing in the apache error_log, or any other log file on the system
    attachments were stored in the filesystem before, i changed to storage in database
    both have the same problem
    it is a dedicated server running some more websites, other websites have no issue with uploading files through PHP

    the diagnostics upload went successfull:

    file_uploads: On
    open_basedir: None
    safe_mode: Off
    upload_tmp_dir: None
    upload_max_filesize: 19.53 GB
    No errors occurred while opening the uploaded file for reading. You should be able to turn off the "Upload In Safe Mode?" option without any adverse effects.

    both with SAFE MODE on and off

    any clue is welcome

  • #2
    Please fill out a support ticket at:

    http://members.vbulletin.com/members...ontactform.php

    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      FYI: The most likely cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory
      on the server that is chmod'd to 1777.

      You will also need to restart Apache after making this change.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        already tried that, forgot to mention in first post, /tmp is 1777
        file_uploads:On
        open_basedir:Nones
        afe_mode:Off
        upload_tmp_dir:/tmp
        upload_max_filesize:19.53 GB

        Comment


        • #5
          Then fill out a support ticket or follow-up on your existing one.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            for the record, it is solved
            My "post_max_size" and "upload_max_filesize" are way too high (2000M and 20000M).
            i changed it to 1000M for both, (1Gb), restarted apache, and this fixed the issue
            important to note here that its a dedicated server with 8Gb of ram.

            answering your next question:
            i need the high number (1Gb) for another collaboration software package on the same server (company file sharing).
            could have done it with .htaccess for this particular site, but didn't think of that at the time.

            thanks to Steve Machol for finding this issue

            Comment


            • #7
              @klaas1 Thank you too.. Changing max_filesize to Lower.. This trick works.after a long time finally it solved my problem ..
              At my server it was 4000M , changed it to 400M . and it is working now..
              Mobile Phone Applications Download Fun and Entertainment

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X