No announcement yet.

Allowed memory size appear in ( index.php ) only

  • Filter
  • Time
  • Show
Clear All
new posts

  • Allowed memory size appear in ( index.php ) only

    I figured the problem in the My site (VB 3.8.1) .. In short, the problem is when I go to the main forum show the following statement:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 51529661 bytes) in /home/******/public_html/forum/includes/functions.php on line 667

    When you browse any of the sections in site is working normally, except the index.php ..
    Tried to use the old database and worked normally, but it would lose a lot of posts ..
    What is the solution to this problem? I hope you can help me, I note you have the replacement functions.php file and turn off all the Hacks, but to no avail.
    I also contacted the hosting and they said I should upgrade to VPS, as the memory that I was provided with 64 megabytes is not only a way to increase upgrade ..
    I thank everyone who contributed to our support.

  • #2
    I suspect you have an add-on that is consuming memory since the default vB code does not required that much. Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' variable in php.ini to at least 128M.

    To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', 128* 1024 * 1024);
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    • #3
      I'm edit the config.php
      the Hosting refuses to increase the value of memory, it asks me to move to VPS plan , as the memory that I was provided with 64 megabytes .
      the problem appear in forum index only .


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.