Announcement

Collapse
No announcement yet.

Hundreds of emails a day [ Database error (Too many connections) in vBulletin 3.8.5 ]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hundreds of emails a day [ Database error (Too many connections) in vBulletin 3.8.5 ]

    I receive hundreds of emails per day
    [ Database error in vBulletin 3.8.5 ]

    Code:
    Database error in vBulletin :
     
    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections
    /home/tvegy/public_html/vb/includes/class_core.php on line 311
     
    MySQL Error   : 
    Error Number  : 
    Request Date  : Monday, August 30th 2010 @ 09:45:44 PM
    Error Date    : Monday, August 30th 2010 @ 09:45:44 PM
    Script        : http://www.tvegy.com/vb/index.php
    Referrer      : 
    IP Address    : 196.205.227.190
    Username      : 
    Classname     : vB_Database
    MySQL Version :
    checked MASTER DATABASE PERSISTENT CONNECTIONS

    Code:
    $config['MasterServer']['usepconnect'] = 0;
    also Increase
    Code:
     max_user_connections=500


  • #2
    The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off by adding this to your config.php (which you already tried):
    PHP Code:
    $config['MasterServer']['usepconnect'] = 0
    But, if you still have the problem you will have to talk to your host about raising that limit. Also, see this Common MySQL Error Messages

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      http://www.vbulletin.org/forum/showthread.php?t=218620 This might be able to help cut down on the error spam.

      Comment


      • #4
        Does anyone know what the cause is because my host does not and they have increased the connections too
        www.falconryforum.co.uk

        Comment


        • #5
          The error is very clear, there are to many connections globaly on the server.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X