Announcement

Collapse
No announcement yet.

Picture albums broke when domain changed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Logician
    Member

  • Logician
    replied
    Originally posted by agurus View Post
    I dont know why its reading files out of my old domain and not new domain?
    You probably solved it out already but I'm writing for people who will have same issue.

    When you change your domain, you need to change file paths in your vb options and cache. If you don't vb will use your old domain's paths (eg. $vbulletin->options['attachpath'] variable will be pointing old server's data structure) and when it tries to read from there, you'll get this error. It has nothing to do with open_basedir restriction in your current server.

    If you enable debug mode in your config.php, login to vb options, you'll be able to modify these paths in the hidden variables of vbulletin.

    Leave a comment:

  • snakes1100
    Senior Member

  • snakes1100
    replied
    Per the settings open_basedir, the images must reside within the forum dir, not outside of them.

    Example:
    Incorrect = /home/username/public_html/useralbums

    Correct = /home/username/public_html/forum/useralbums

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    So any idea? Can I open a ticket/get official help?

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    Originally posted by Lynne View Post
    Are you album images stored in the database or the filesystem?
    File system

    Leave a comment:

  • Lynne
    Former vBulletin Support

  • Lynne
    replied
    Are you album images stored in the database or the filesystem?

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    And if there are traces you want me to change it to my new domain?

    Also, what about uploading? Why do I get errors for that - is the issue related?

    Leave a comment:

  • Loco.M
    Senior Member

  • Loco.M
    replied
    Originally posted by agurus View Post
    No I have not - I am not really good at MYSQL but I have a general idea...can you point me of what I should be looking for and where?

    I also wanted to clarify this issue occurs when trying to VIEW an image uploaded to albums or upload one
    do you have access to phpmyadmin?

    if so, you can search for any traces of your old domain

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    No I have not - I am not really good at MYSQL but I have a general idea...can you point me of what I should be looking for and where?

    I also wanted to clarify this issue occurs when trying to VIEW an image uploaded to albums or upload one
    agurus
    Senior Member
    Last edited by agurus; Mon 16 Aug '10, 12:05pm.

    Leave a comment:

  • Loco.M
    Senior Member

  • Loco.M
    replied
    Originally posted by agurus View Post
    I dont know why its reading files out of my old domain and not new domain?
    I'm guessing it's still being called in the database..
    have you searched it?

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    The tmp directory was already correct in admincp, and it was present in home/domain2/tmp (also set it to 777, was at 755), I enabled "Safe Mode Upload Enabled", and still no luck.

    Upon uploading i get this error:
    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/home/domain1/public_html/albums/1) is not within the allowed path(s): (/home/domain2:/usr/lib/php:/usr/local/lib/php:/tmp) in [path]/includes/functions_file.php on line 60


    I dont know why its reading files out of my old domain and not new domain?

    Leave a comment:

  • Lynne
    Former vBulletin Support

  • Lynne
    replied
    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /home/yoursite/tmp

    Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

    Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes

    Also the php.ini setting for 'upload_tmp_dir' may be empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    I reuploaded the files twice on my server and had no luck (even ran the upgrade script again)

    What do I ask my host to do about the open_basedir?

    Leave a comment:

  • Trevor Hannant
    vBulletin Support

  • Trevor Hannant
    replied
    Try re-downloading the ZIP file from the Members Area and re-upload all files (except install/install.php and includes/config.php.new) making sure you overwrite all files currently on your server.

    Also, you may need to speak to your host regarding the open_basedir settings on your server

    Does this resolve the problem?

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    Can anyone please assist me in this?

    Leave a comment:

  • agurus
    Senior Member

  • agurus
    replied
    no help?

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X