Announcement

Collapse
No announcement yet.

Having an issue on our fansite forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having an issue on our fansite forum

    Hello! I am co admin for a forum at www.stillnsync.com/board. This software has been installed for over a year without a problem. I posted a thread earlier today and this afternoon went back and I am getting the following error:

    Fatal error: Call to a member function query_first_slave() on a non-object in /home/nsync908/public_html/stillnsync/board/includes/functions.php on line 2021

    I attempted a databse fix from the Control panel but that did nothing. I also spoke to tech support at our host site, who had no clue but pointed me here.

    I've done a google search but didn't find anything that fixes this issue. Does anyone know what this means, what causes it and how it can be fixed?

    Many thanks in advance!

    Moke
    www.stillnsync.com

  • #2
    I don't if this should be the correct answer, but I'd reupload original files (don't forget to make a backup first)
    I could sell you my unused vB4 Suite license, but I'm not so cruel...

    Comment


    • #3
      Thanks. I don't usually mess around with these files so I'm nervous to just go uploading things. Trying to locate the admin but she is out of reach.

      Comment


      • #4
        For testing thinks like this it's very useful to have ssh access. If it don't work, you can restore it in a few secs. Much faster than uploading a lot of files by FTP.

        tar -cvf backup.tar public_html

        to restore:

        tar xvf backup.tar
        I could sell you my unused vB4 Suite license, but I'm not so cruel...

        Comment


        • #5
          Has this happened after adding a new modification/plugin?

          Disable products & stuff globally like this:

          Edit your config.php file (found in /includes/config.php) to have this code below the <?php line (right at the top)

          PHP Code:
          define('DISABLE_HOOKS'true); 
          Then reupload and see if the problem still occurs.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X