No announcement yet.

Uploads from Windows 7

  • Filter
  • Time
  • Show
Clear All
new posts

  • Uploads from Windows 7

    We can upload attachments to the forum perfectly all right from Windows XP workstations, but attempts from Windows 7 produce timeouts and only smaller files can be uploaded. The problem happens in both IE8 and Firefox 3.6.3. In fact, an HTTP upload from Windows 7 to a Joomla site on the same server also times out. Uploading to both sites works if the browser is runs from Windows XP.

    Server Environment:
    Windows Server 2003
    Apache 2.2.6
    PHP 5.2.5
    vBulletin 3.8.4PL1

    Windows 7 Enterprise with latest updates and network drivers
    IE8, Firefox 3.6.3
    Windows Firewall turned off
    Symantec Endpoint Protection (turning off does not make a difference)

    Smaller files, under 500KB, can be uploaded all right but files larger than 1MB fail. The sizes of the uploaded files are considerably smaller than the maximum sizes set in the Attachment Manager and the PHP settings - and everything works from Windows XP using the same automatic proxy configuration script for the LAN.

    Settings from php.ini:
    max_input_time 3600
    max_execution_time 3600
    upload_max_filesize 512M
    post_max_size 512M
    memory_limit 1024M

    PHP error log:
    [19-May-2010 10:21:49] PHP Fatal error: Maximum execution time of 3600 seconds exceeded in D:\www\production\forum\newattachment.php on line 14

    This does not make sense for a 2MB file because the same file can be upload from XP in 10 seconds. Therefore the upload has hung but the server keeps counting.

    I used Windows 7 to upload from public internet to the same server and that also timed out. Is Windows 7 getting confused in its interaction with proxy servers or the other way round?

    Web Developer
    Sydney, Australia

  • #2

    Can you please let us know if the user under Windows 7 is running in Administrator mode?

    We have seen this problem before when a user was not an administrator and certain restrictions were in place on the file system.

    Example: In Windows Vista Enterprise, if user doesn't have certain access rights they cannot upload files from the local file system to certain websites. I've seen his happen with vBulletin, Google Mail attachments, etc. (Getting timeouts, etc.)

    I only have access to the Vista Enterprise, but it sounds like the same problem.

    Let us know.
    To be updated...


    • #3

      Both the local user and the domain user that I have used are members of the Administrators group. Our corporate IT does not support Windows 7 as yet, but our software developers are about to start using Windows 7. Could the AD policies meant for XP somehow cause the uploads to be restricted?

      Web Developer
      Sydney, Australia


      • #4
        I suppose it's possible; but I have not had any experience [yet] of adding Windows 7 to an existing domain that was originally a mix of XP and Vista.

        What gets me, is that the smaller files go and the larger ones do not. A friend in the office seems to think it's an issue between Win7 and your proxy or firewall.

        Suggestion: Push out a large file to one of those sites and see if Windows 7 is waiting for the website to acknowledge the transfer. Or does it dump the transfer out only go get blocked by the proxy? Use your task manager/network monitor to watch the network traffic. If it spikes with a transfer attempt and then nothing happens, then I bet it's getting blocked somewhere internally. (if there's no attempt, then I guess Windows 7 problem...)

        A quick search turned up a few people having problem with 3rd party AV/Firewall/Security products. But, that's it...

        Not knowing your internal info, can't say for sure... just giving out some ideas.
        To be updated...


        • #5
          Thanks for the advice. In the Task Manager smaller files like 300KB show the spike and are uploaded all right. The larger files display the spike, then nothing happens and the display stays at "Uploading File(s), Please Wait".

          I will talk to the network administrators to see what they have to say.

          Web Developer
          Sydney, Australia


          • #6
            If I had to guess its deep packet filtering/inspection.


            • #7
              Update: two more users reported the same problem with uploads from the LAN.

              A couple of days ago I replaced the latest version of the network driver from the laptop manufacturer (June 2009) with the latest version of the driver from the network card manufacturer Intel (April 2010). I was then able to post an 8MB attachment from my home network through the public internet to the forum using a LAN connection on one ISP and a wireless router connection through another ISP. However, attempts to upload from inside LAN to the server in DMZ still fail.

              I captured the packets from the Windows 7 laptop and the responses from the server indicate that it has missed packets. The upload never finishes and the same error is reported by the server: PHP Fatal error: Maximum execution time of 3600 seconds exceeded in ... \forum\newattachment.php on line 14. Today I spent a couple of hours with a firewall administrator who removed all rules and barriers so that the Windows 7 laptop could try to upload a 2MB file from the LAN directly to the server in DMZ. Still no luck.

              Strangely, I can upload an attachment from the same Windows 7 laptop to my test server in the LAN, Windows Server 2003 running an identical setup as the server in the DMZ. The test server is in the next office, therefore the packets from my laptop only go through the switch in the local rack before they are routed to the server. The connection from the office building to the remote data centre hosting the DMZ is more complex but why would that be a problem for Windows 7 when Windows XP worked all right in the office when I installed it earlier on this particular laptop? And the same laptop can post without problems from the public internet, going through the same firewall?

              Web Developer
              Sydney, Australia


              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.