Announcement

Collapse
No announcement yet.

Problems with database and server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • iadmirevb
    replied
    Found what the problem was! My fault... I've created a plug-in like this:

    -----------------------------------------
    ob_start();
    include('http://www.mysite.com/header/header.php');
    $include_clubheader = ob_get_contents();
    ob_end_clean();
    -----------------------------------------

    and i was inserting it in the header template like this:

    -----------------------------------------
    <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"></script>
    <script>jqcc=jQuery.noConflict(true);</script>
    <!-- FANCLUB - HEADER -->
    $include_clubheader
    <!-- /FANCLUB - HEADER -->

    <!-- content table -->
    $spacer_open

    $_phpinclude_output
    $ad_location[ad_header_end]
    -----------------------------------------

    Once i disable it, the forum started the run normally... my customers are now happy. The think i don't get is that it was created 3 months ago and it took so long to cause problems....oh well... at least it works...

    Maybe it was a conflict with jquery or else... Now i need to work on how to get the header on my forum...

    Leave a comment:


  • Homeworld'sa
    replied
    MySQL has gone away is a result of your host. Since you've contacted them to no avail, try here for solutions:
    http://www.vbulletin.com/docs/html/t...mysql_goneaway

    Leave a comment:


  • borbole
    replied
    Originally posted by iadmirevb View Post
    I'm on a shared host plan... I have a very small community so far... 400 users, no more then 25 users a day...
    I've contacted my host yesterday, they say that they are working on it with no more details... Hopefully this is a problem by my host and not a corrupted database...
    This is definitely a hosting problem.

    Leave a comment:


  • iadmirevb
    replied
    no... still no solution. Yesterday, everything was ok and today it's started all over again. I feel like the forum is beeing attacked... It's frustating!

    Leave a comment:


  • JamesAB
    replied
    Contact your hosting provider and see what they can do for you.

    Leave a comment:


  • iadmirevb
    replied
    Originally posted by JamesAB View Post
    If your are on on a VPS or dedicated server, take a look at your wait_timeout in my.cnf . Otherwise, contact your host.

    http://www.vbulletin.com/docs/html/t...mysql_goneaway
    I'm on a shared host plan... I have a very small community so far... 400 users, no more then 25 users a day...
    I've contacted my host yesterday, they say that they are working on it with no more details... Hopefully this is a problem by my host and not a corrupted database...

    Leave a comment:


  • JamesAB
    replied
    If your are on on a VPS or dedicated server, take a look at your wait_timeout in my.cnf . Otherwise, contact your host.

    http://www.vbulletin.com/docs/html/t...mysql_goneaway

    Originally posted by eva2000
    If you get mysql server gone away error messages, then keep increasing wait_timeout value in my.cnf by 60 second increments, then restart mysql after my.cnf changes for it to take effect. Test for a few days and see if you get less or eliminate that error message. If it still occurs, then keep repeating the 60 second increment until the message goes away. Each vB forum and server will have different optimal wait_timeout values depending on your vB forum traffic patterns and server hardware specifications.

    Leave a comment:


  • iadmirevb
    replied
    just want to mention that my administration panel is working and responding as it should... the problem doesn't affect the administration side, just the forum

    Leave a comment:


  • iadmirevb
    started a topic Problems with database and server

    Problems with database and server

    Hello,
    Everything was working well until yesterday. For the past 3 days, users are complaining that the forum is too slow or not responding.

    I keep receiving erros like this one every 10 minutes or so:

    Database error in vBulletin 3.8.4:

    Invalid SQL:
    DELETE FROM vb_strikes WHERE striketime < 1272600884;

    MySQL Error : MySQL server has gone away
    Error Number : 2006
    Request Date : Friday, April 30th 2010 @ 12:14:44 AM
    Error Date : Friday, April 30th 2010 @ 12:15:26 AM
    Script : http://www.___
    Referrer : http://www.___
    Referrer :
    IP Address : -
    Username : Admin
    Classname : vB_Database_MySQLi
    MySQL Version :

    ---

    Database error in vBulletin 3.8.4:

    Invalid SQL:

    SELECT noticeid
    FROM vb_noticedismissed AS noticedismissed
    WHERE noticedismissed.userid = 1;

    MySQL Error : MySQL server has gone away
    Error Number : 2006
    Request Date : Friday, April 30th 2010 @ 12:23:33 AM
    Error Date : Friday, April 30th 2010 @ 12:24:03 AM
    Script : http://www.___
    Referrer :
    IP Address : -
    Username : Admin
    Classname : vB_Database_MySQLi
    MySQL Version :



    Is this a problem from my host (HostGator) or the database?

    Please Help.

Related Topics

Collapse

  • datacrux
    Database Erorr
    by datacrux
    Hello I always recive erorr message regarding database erorr at my email.

    Here is an email :

    Database error in vBulletin 5.0.5:Invalid SQL:/** saveDbCache */ SELECT * FROM cacheevent...
    Fri 21st Feb '14, 8:29pm
Working...
X