Announcement

Collapse
No announcement yet.

Large file upload fails with 404

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Large file upload fails with 404

    Hi,

    I just tried to upload a large mp3 file to my site and the upload window goes to a 404 after about 2+ minutes.

    I already set the VB attachment size to be larger. The folder has write permissions and I tested file uploads in admincp.

    Also, I checked PHP:

    upload_max_filesize: 70.00 MB

    post_max_size = 70M
    memory_limit = 128M
    max_input_time = 300

    The strange thing is that it fails with a 404 and not a PHP or VB message.
    Last edited by trana; Mon 26 Apr '10, 6:26am.

  • #2
    I am still having this problem, can anyone tell me what else I should check?

    Thanks!

    Comment


    • #3
      A couple questions:

      * Which version of vBulletin?
      * Which browser are you using to upload? Did you try another browser? Does anyone else have a problem?
      * Do you have any problems with smaller files?

      I assume you have attachments going into a folder and not the database, from your previous statement, but check again at ACP > Attachments > Attachment Storage Types and make sure.

      Comment


      • #4
        3.8.4
        Firefox, everyone else has the same problem.
        No problems with smaller files, we have previously uploaded 40Mb with no problems. Now we need to go to 70, I raised everything as per the original post and it still fails with a browser 404 error.

        Comment


        • #5
          I've seen similar problems when the LimitRequestBody directive in httpd.conf is set lower than the upload_max_filesize in php.ini
          If you read it online, it must be true.

          Comment


          • #6
            I am running the site on IIS, do you know what the equivalent is?

            Comment


            • #7
              Anyone?

              Comment


              • #8
                look at the MySql max packet size too!, you may alsoe need to change the wait_timeout in my.cnf
                Kind regards,
                Simon
                Microsoft Office Discussion

                Comment


                • #9
                  I have:

                  max_allowed_packet=80M

                  I do not have a wait_timeout set. What should I set it to?

                  Is it necessary to change my.ini if I am writing attachments to the filesystem and not the db?

                  Comment


                  • #10
                    Anyone?

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X