Announcement

Collapse
No announcement yet.

Make A Copy Of My Forum For A Test Forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Make A Copy Of My Forum For A Test Forum

    What would be the best way to make an exact copy of my site, so i can use it as a test site?
    Of course i'll name the directory testvb & password protect it.

    I want to do it because of the 3.8.5 updates, i want to test the upgrade before i upgrade my live site. To see if my custom skin is ok or needs work doing to it.

    Im hoping there's a easier way than install 3.8.4 PL1, then all my mods...

  • #2
    i don't think you can.
    Just upload all of the vb zip files to your test folder and install it again (configuring it and making a db)
    That's it. If you REALLY can't say ANYTHING nice to me at all on this forum, then I am going to go insanely mad at you. I've had enough of the UNTOLD ABUSE you are all giving me and you should really be CONSIDERATE of other people.

    Comment


    • #3
      Originally posted by Dj Smuggla View Post
      What would be the best way to make an exact copy of my site, so i can use it as a test site?
      Of course i'll name the directory testvb & password protect it.

      I want to do it because of the 3.8.5 updates, i want to test the upgrade before i upgrade my live site. To see if my custom skin is ok or needs work doing to it.

      Im hoping there's a easier way than install 3.8.4 PL1, then all my mods...
      Move your forum files to the test folder. Create a new database and restore there a copy of your main forum's db. Then change the config.php file at your test folder to point to that new database and at the Acp-Settings-Options-Help-Site Name / URL / Contact Details -Forum URL. And here change the url to that of your test forum and you should be all set.

      Or install a vb at your test folder usinga new database and then do the procedure with the restore and forum url update.

      Comment


      • #4
        First, I think borbole's idea will work to a point. The problem will be if the MODs installed/created multiple database tables.

        So, here's another procedure:

        I've done this ONCE. It worked ONCE. So, make backups. Make backups of your backups.

        Don't try this if you don't understand any step.

        0. Make backups. You'll need to play with the backup of your SQL database, at the very least.
        1. Create a new empty database for vBulletin.
        2. Use phpMyAdmin or equivalent to make sure your new database has all the same tables that your LIVE, WORKING database has. You'll probably have to add several.
        3. Install the same version of vBulletin that you CURRENTLY have in a different directory. Make sure you're pointing to your new database, of course.
        4. Make sure your new install works (i.e. does the forum open? No graphics errors? Etc.).
        5. Copy your entire live forum directory on your webserver, EXCEPT for the vBulletin config.php file.
        6. Paste the entire live forum directory, EXCEPT for the config.php file, over your new forum's directory. Replace the files.
        7. Use phpMyAdmin or equivalent to restore your live forum database to the new forum database.
        8. Cross your fingers and pull up the new forum in a browser.
        9. If it works, install 3.8.5 and do your testing.

        Again, I've done this ONCE and it worked. When I did this, tho, I had only one or two MODS. The reason WHY I did this was because the database became corrupt and I had to try to restore bits and pieces from several backups.

        Comment


        • #5
          Originally posted by prisoner 24601 View Post
          The problem will be if the MODs installed/created multiple database tables.
          That won''t matter at all.

          Comment


          • #6
            Thanks a lot for all your replys guys, im gunna try borbole's method as it seams pretty easy...

            I'll let you know how it went lol

            Comment


            • #7
              Yea thanks a lot borbole that worked nicely, a very quick way to make a clone...

              Now i just gotta fix a few things from the upgrade...

              Comment


              • #8
                Originally posted by Dj Smuggla View Post
                Yea thanks a lot borbole that worked nicely, a very quick way to make a clone...

                Now i just gotta fix a few things from the upgrade...
                You are welcome Dj Smuggla.

                What errors are you getting with the upgrade?

                Comment


                • #9
                  It's totally messed up my skin, the only thing showing is the header banner & the footer image.
                  All the other images don't load.

                  Here's a screen of the acp:
                  http://i39.tinypic.com/2s0danb.jpg

                  Here's a screen of my skin on my live site 3.8.4 PL1:
                  http://i40.tinypic.com/vfzciw.png

                  Here's a screen of my skin on my updated test site 3.8.5:
                  http://i43.tinypic.com/2zye8no.png

                  Im stuck on this, so hopefully you'll know m8...

                  I made a new thread so it don't go off topic:
                  http://www.vbulletin.com/forum/showt...18#post1961818
                  Last edited by Dj Smuggla; Sat 10 Apr '10, 4:30am.

                  Comment


                  • #10
                    Maybe the skin will need some edits to be compatible with the 3.8.5. I don''t think I an be of anymore help as I am not familiar with the 3x series. But hopefully someone who is will help you further.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X