Announcement

Collapse
No announcement yet.

Login issues after upgrading from 3.7.1 to 3.8.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Login issues after upgrading from 3.7.1 to 3.8.5

    Hi,

    I upgraded www.btcf.fi/forum from 3.7.1 to 3.8.5. We have ~25k users and ~1.4 million posts. We did not face any login issues with 3.7.1 but got some issues after upgrade.

    I'm logging in with Remember Me box checked. Forum works fine, but sometimes when I'm opening a section/thread/post it throws me to the login page (You are not logged in or you do not have permission to access this page. This could be due to one of several reasons If I refresh the page it forwards me the section/thread/post I requested in the first place.

    I cleared the cookies but it didn't help.

    Path to Save Cookies: /forum/ [options / and /forum/ ]
    Cookie Domain: (blank) [options: (blank) and .btcf.fi]

    This is affecting many users with different OS and different browsers. I don't have any specific way to reproduce the issue. It just sometimes appears.

    Hopefully somebody can help with this issue.

    Cheers,
    Doni

  • #2
    The login issues are probably caused by the "cookie salt" changes in 3.8.4pl2 and later and probably can be resolved the same way: user has to log out and then delete his cookie for your forum and then log back in. (I've had a very small percentage of users with this problem and this fix always worked.)

    As far as the ACP is concerned, if you only have one vBulletin forum, the path to save cookies should just be "/" (no custom setting). The cookie domain should be ".example.com" (no custom setting), unless you have an odd set-up.

    Comment


    • #3
      I have the settings you mentioned but still the same problem. Cookies are also cleared.

      The forum doesn't kick me out, it just shows the "You are not logged in" page. Hitting F5 and it shows you as logged in again.

      Comment


      • #4
        This is exactly the issue I've been seeing, have you resolved it?

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X