Announcement

Collapse
No announcement yet.

RSS feed won't create threads automatically

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RSS feed won't create threads automatically

    Hi,

    I currently have a feed set up to automatically create a thread whenever I publish a Wordpress post.

    When I first started the forum, it used to create threads just fine, with the last few posts I've made recently however, they're just not updating.

    I tried waiting a day or two, with no luck (It's supposed to check the feed every 20 minutes). However when I manually click on "Run Scheduled Task Now" for the appropriate feed in the Admin Panel, they're created right away.

    The feed manager window even says it hasn't checked the feed in about a month or so (last time I ran the task). Yet I still have the "Check Feed Every..." option set to 20 Minutes. This is why I'm baffled here.

    Any Ideas?
    Engipress - Wordpress Resources and Information

  • #2
    Have you edited your footer file at all? Are other Scheduled Tasks running OK?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      I only added a link or two to my footer that's about it.

      Every other task seems to be running just fine.
      Engipress - Wordpress Resources and Information

      Comment


      • #4
        I'm having this issue as well.. The only way to get them to work is to run it manually..
        Ball Python Forum l Cottonmouth Snake l Reptile Husbandry

        Comment


        • #5
          Check that the cronjob file exists in the includes/cron folder of your forums
          If it is there, check the scheduled task is even enabled.
          That's it. If you REALLY can't say ANYTHING nice to me at all on this forum, then I am going to go insanely mad at you. I've had enough of the UNTOLD ABUSE you are all giving me and you should really be CONSIDERATE of other people.

          Comment


          • #6
            Yea I checked all those things. The only way I can get mine to work even in the manual mode is to reset each feed after each run. It won't even allow me to run two manual runs in a row without resetting each feed first..
            Ball Python Forum l Cottonmouth Snake l Reptile Husbandry

            Comment


            • #7
              Then there is a modification that is tampering with your RSS Feed Syndication.
              Disable all your modifications (either via config.php or the plugin/hook setting switch in the vBulletin Options) and see if the problem is fixed.
              That's it. If you REALLY can't say ANYTHING nice to me at all on this forum, then I am going to go insanely mad at you. I've had enough of the UNTOLD ABUSE you are all giving me and you should really be CONSIDERATE of other people.

              Comment


              • #8
                Ok I figured out the issue and hopefully it will work for others that are experiencing a similar problem. It is not a modification issue. Once you reset all the feeds do not do a manual run task just leave it alone and allow it to run as scheduled. Works like a charm for me now...
                Ball Python Forum l Cottonmouth Snake l Reptile Husbandry

                Comment


                • #9
                  Originally posted by Homeworld'sa View Post
                  Check that the cronjob file exists in the includes/cron folder of your forums
                  If it is there, check the scheduled task is even enabled.
                  What's the name of the file, cronjob.php? I have about 20 different PHP files inside the includes/cron folder. (And there isn't a cronjob.php file there.)

                  Originally posted by General Lee View Post
                  Ok I figured out the issue and hopefully it will work for others that are experiencing a similar problem. It is not a modification issue. Once you reset all the feeds do not do a manual run task just leave it alone and allow it to run as scheduled. Works like a charm for me now...
                  Did you check the reset feed box, or did you click on the reset button at the bottom of the feed edit page?

                  The latter did nothing for me. Hopefully checking the box and resetting it works!
                  Engipress - Wordpress Resources and Information

                  Comment


                  • #10
                    Originally posted by jamestl2 View Post
                    What's the name of the file, cronjob.php? I have about 20 different PHP files inside the includes/cron folder. (And there isn't a cronjob.php file there.)
                    no, that folder contains the 20 cronjob's that get run by cronjob.php (no idea where that is located). They are required for the default cron jobs installed on vB
                    That's it. If you REALLY can't say ANYTHING nice to me at all on this forum, then I am going to go insanely mad at you. I've had enough of the UNTOLD ABUSE you are all giving me and you should really be CONSIDERATE of other people.

                    Comment


                    • #11
                      Originally posted by jamestl2 View Post
                      Did you check the reset feed box, or did you click on the reset button at the bottom of the feed edit page?

                      The latter did nothing for me. Hopefully checking the box and resetting it works!
                      I clicked the reset in the top left of each rss feed throught admincp > rss feed manager > edit feed
                      Ball Python Forum l Cottonmouth Snake l Reptile Husbandry

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X