Announcement

Collapse
No announcement yet.

Trying to ban spammers, but they are being shown as guests

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to ban spammers, but they are being shown as guests

    Hello,

    I'm a simpleton newby so please excuse my remedial knowledge.

    Thanks for taking the time to help me......
    When I try to ban users who are spamming they are now being displayed as
    .
    ....
    Affected Users
    The user(s) who posted the spam are:
    1. N/A

    Affected IP Addresses
    The IP addresses used to post the spam are:
    1. N/A

    Applying Punitive Action To


    All selected users are guests, therefore no punitive actions can be applied.



    They all have usernames, so this mean they are registered right so why can't I ban them for spamming?


    My former developer did some work on the forums and then this started happening, he's no longer with us so I now have to try to figure it out.



    Thanks for any help, it is appreciated!
    Last edited by LocallyLocated; Sun 28 Mar '10, 7:34pm.
    If web development was football, I would be a cheerleader.
    http://locallylocated.com
    http://crystalpointagent.com

  • #2
    Nobody has encountered this problem of not being able to ban spammers because their IP isn't being shown in the adminCP?

    I can't figure out what I think is aregistered user is being displayed as guests and their IP's aren't available to to ban them as spammers.

    There is no information in their user profiles found in the adminCP, however they have usernames?

    My board is being overrun can someone please help me?
    Last edited by LocallyLocated; Mon 29 Mar '10, 5:35pm.
    If web development was football, I would be a cheerleader.
    http://locallylocated.com
    http://crystalpointagent.com

    Comment


    • #3
      I think I am making some progress here.

      I created a user and I logged in to find out my old developer had some how activated the COPPA function? I have turned it off now but I'm not sure how to correct the users permissions who had registered during the time the COPPA was activated. These people are being shown as registered users, however their profiles in adminCP are blank and there are no IP's logged.

      My question is how do I figure out how to ban these spammers without their IP's? Are the people who registered at this time a member of a unique usergroup that I'm not seeing? Many are spammers, but some are not so I am assuming I will have to manually delete them one by one, is this correct?

      Here is what the users profile showed me when i logged into their CP.......


      When you make changes to this profile, your Parent / Guardian will be notified by email.

      If you are over the age of 13, you should not be seeing this message. Please contact the administrator with your username, and your account will be changed.

      To print out a new permissions form, please click the button below.
      If web development was football, I would be a cheerleader.
      http://locallylocated.com
      http://crystalpointagent.com

      Comment


      • #4
        You can change the forum posting permissions from your vBulletin admin control panel->Usergroups->UserGroup Manager. The guest users are associated with the Unregistered / Not Logged In user group. Just modify its permissions.

        Also, you can check the following article on how to fight with the spam in your forum:

        http://kb.siteground.com/article/Blo...Honey_Pot.html
        SiteGround Technical Support Team Member.
        Check out our special vBulletin hosting package.

        Comment


        • #5
          Originally posted by sven4o View Post
          You can change the forum posting permissions from your vBulletin admin control panel->Usergroups->UserGroup Manager. The guest users are associated with the Unregistered / Not Logged In user group. Just modify its permissions.

          Also, you can check the following article on how to fight with the spam in your forum:

          http://kb.siteground.com/article/Blo...Honey_Pot.html
          Thanks for taking the time to respond, it is appreciated.

          The problem is, these posters are members of the registered user group, which is why I am having so many problems.

          If I search a user by the username their profile shows as totally blank.

          From here I hit save after entering no information, which prompted me to enter the users name I searched. This caused me to be prompted with "this user already exists, to edit their profile click here"

          I click on the link and it takes to the fully populated profile of the original user I searched, from here I had to disable COPPA, for the good users and have to manually delete the spammers. Their are over a 1,000 spammers and it will take weeks to get through them all unless someone has a better idea?

          This is all very odd because I searched for the usergroup "COPPA" and it only showed the additional users like the admin and showed no "COPPA" users. It's all very weird and doesn't make much sense to me.
          If web development was football, I would be a cheerleader.
          http://locallylocated.com
          http://crystalpointagent.com

          Comment


          • #6
            make sure human verification is a Q&A

            also this site has a good vbulletin plugin

            http://www.botscout.com/code.htm

            Comment


            • #7
              It's got nothing to do with any of those suggestions. We've got the same thing happening on VB4.

              User still gets banned though.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X