Announcement

Collapse
No announcement yet.

Using 3.8.3 and no access to 3.8.5 to fix security issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using 3.8.3 and no access to 3.8.5 to fix security issue

    I am perfectly content to continue to use 3.8.3 for the rest of my time. It bugged me some that my lifetime license since 2004 now won't let me upgrade to 3.8.5, but I figured I'd be okay without it. But now there's a security issue I am concerned about that appears to not have a security patch for 3.8.x, only a full upgrade to a version I can't get without paying an exorbitant amount for.

    What can I do to patch my version of vBulletin. I can't afford the upgrade price. Will a patch be supplied to vulnerable versions for those of us who can't or don't want to upgrade to 3.8.5 or better?

    R'gards,

    Jim
    If my post was helpful to you, please take the time to register at my forum and ask a question you've always wanted to know about floors.
    www.TheFloorPro.com

  • #2
    Didn't they say that the 3.x licenses are under the 3.x license type and that THAT license type is respected?
    So .. not sure why there isn't a patch, and why this is a forced to renew upgrade, the 3.8.5 announcement didn't even mention Anything about it being a security release.

    Comment


    • #3
      does it matter if its a security update or not? No.. the point is he has an owned lic for a product that he now has no way of getting updates for without paying the vB4 extortion prices.
      Steve, Webmaster and Admin
      www.pokecommunity.com

      Comment


      • #4
        It matters because if it's a security update it should be available without purchasing a new license.

        Comment


        • #5
          Yes it matters, since as with every version if your license expired you won't have access to future releases, such as upgrades and maintenance releases. The renewal option has disappeared. One has to upgrade to v4 license type, to get access to all non-EOL-ed releases, such as 3.8.5 currently is.

          However, security patches have always been free, and downloadable by expired licenses. And since his license falls under the 3.x license type, in my opinion, therefor should still have, since he never upgraded to any new license type. They completely skipped it for 3.8.5 it seems, and I am wondering out loud if this is to "force" people to pay the renewal price.

          Comment


          • #6
            that's my thoughts as well.. they want the $$

            I have a 3.8.x owned lic as well (also a 4.0.x lic) and ONLY bought into 4.0 to continue updates.. for the most part. In fact, I'm treating them as seperate licenses since I did PAY FULL PRICE for BOTH licenses.

            I seriously do hope the current vB team offers the security fixes freely as they have always done..
            Steve, Webmaster and Admin
            www.pokecommunity.com

            Comment


            • #7
              Originally posted by Floris View Post
              Didn't they say that the 3.x licenses are under the 3.x license type and that THAT license type is respected?
              So .. not sure why there isn't a patch, and why this is a forced to renew upgrade, the 3.8.5 announcement didn't even mention Anything about it being a security release.
              The license snafu has been so convoluted, I haven't followed it closely enough to understand it. Just before my so-called lifetime license "expired," I downloaded the latest version available to me, 3.8.4 PL2. Unfortunately, there were upgrade problems with 3.8.4 and I wanted no part of it. I stayed on 3.8.3. No security issues were involved in that release until one of the PL's for 3.8.4. But I didn't upgrade because the issue didn't seem to be a big enough concern for me at that time.

              Now that I am concerned, I wonder why there isn't a security patch for those of us who can't upgrade to 3.8.5 or 4.x. I have tried to stay peaceful about the whole upgrade policy change. It pisses me off, but I don't have a lot of time left (lung disease) and don't want what I have left to be filled with contentious condemnation and struggle with a company that doesn't really care about me anyway. It may sound crass or even irresponsible, but let my forum's beneficiaries deal with it after I'm gone.

              Jim
              If my post was helpful to you, please take the time to register at my forum and ask a question you've always wanted to know about floors.
              www.TheFloorPro.com

              Comment


              • #8
                I think it is not unlikely that a rewritten patch that's unofficial will be released on sites like vbfans.com and adminextra.com - seeing this effects a good amount of customers looking for free support.

                [edit] decided to give it a try: http://vbfans.com/showthread.php?t=79774
                Last edited by Floris; Tue 23rd Mar '10, 4:31am.

                Comment


                • #9
                  Originally posted by eJM View Post
                  What can I do to patch my version of vBulletin. I can't afford the upgrade price. Will a patch be supplied to vulnerable versions for those of us who can't or don't want to upgrade to 3.8.5 or better?

                  R'gards,

                  Jim
                  My questions have not been responded to by support staff. Am I in the wrong forum for these questions?
                  If my post was helpful to you, please take the time to register at my forum and ask a question you've always wanted to know about floors.
                  www.TheFloorPro.com

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X