Announcement

Collapse
No announcement yet.

Parse error - Unable to add cookies, header already sent - class_dm_user.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MRGTB
    replied
    Unable to add cookies, header already sent.
    That error message above that I quoted, could mean you have an extra blank space that needs deleting either before or after your PHP opening and closing brackets top of and bottom of your php file.

    Code:
    <?php
    Code:
    ?>
    It should be like this example:

    <?php

    your code

    ?>
    And not like this example:

    Code:
    [COLOR=Red]SPACE[/COLOR]
    <?php
    SPACE
    
    your code
    
    SPACE
    ?>
    [COLOR=Red]SPACE[/COLOR]
    Check were I typed "space" to see if you have any like that to be removed, then re-upload your file to see if the error goes away. Especially were I highlighted it in RED.

    EDIT: Ah, sorry I see this was sorted by Lynne
    Last edited by MRGTB; Thu 11 Mar '10, 9:30pm.

    Leave a comment:


  • ENF
    replied
    Originally posted by stangfan.com View Post
    Hi Lynne

    Interesting.. The phrase was there. I reverted it to a default phrase and ta-da

    Worked!

    Thanks very much
    Very good, glad to hear that got sorted out. Some answers are so simple.... :P

    Leave a comment:


  • niceguy2010
    replied
    Originally posted by Lynne View Post
    Did you check the welcomepm phrase text?
    Hi Lynne

    Interesting.. The phrase was there. I reverted it to a default phrase and ta-da

    Worked!


    Thanks very much

    Leave a comment:


  • Lynne
    replied
    Did you check the welcomepm phrase text?

    Leave a comment:


  • niceguy2010
    replied
    Originally posted by Lynne View Post
    When you reuploaded all your files, were they all default files? Did you have to edit any of them for your modifications?
    Hi Lynne

    No files require editing. They are all stock default files.

    Leave a comment:


  • Lynne
    replied
    When you reuploaded all your files, were they all default files? Did you have to edit any of them for your modifications?

    Leave a comment:


  • niceguy2010
    replied
    wouldn't disabling them from the config file be enough as apposed to removing them 1 by 1?

    Leave a comment:


  • ENF
    replied
    Ok.

    Based on what I can tell and what evidence is provided, it looks like it's a plug in problem. (or at least caused by a plug in) I know you already stated that you disabled plug-ins from the config.php, but I can't find a similar case to yours that didn't involve a broken plug-in. As much of a pain as it may be, you could disable one plug in at a time to see if the error goes away.

    The ONLY other thing I can come up with is if you didn't upload the files properly in ASCII format.... however, that seems unlikely since you are only getting this one error.

    I'll dig around a bit more and see if anything comes up. That's all I can offer at the moment.

    Leave a comment:


  • niceguy2010
    replied
    Originally posted by ENF View Post
    Oh, Well...

    Are you using an image gallery plugin, if so which one?

    No gallery pluggins installed, but the site does have 1 instance of Photopost but its not integrated with the site with regards to portal images or anything.

    Leave a comment:


  • ENF
    replied
    Oh, Well...

    Are you using an image gallery plugin, if so which one?

    Leave a comment:


  • niceguy2010
    replied
    Originally posted by ENF View Post
    When did this error start occurring? Where there any changes or uploads made to your forums directory preceding these errors?
    I wasn't aware of it not working until I recently made an account. Upon further research I see it stopped working around
    08-30-2009, 07:46 PM

    Sadly, I am unaware of what may or may not have changed around that time as its been some time since (7 months approx).

    Leave a comment:


  • ENF
    replied
    When did this error start occurring? Where there any changes or uploads made to your forums directory preceding these errors?

    Leave a comment:


  • niceguy2010
    replied
    anyone?

    Leave a comment:


  • niceguy2010
    replied
    anyone?

    Leave a comment:


  • Parse error - Unable to add cookies, header already sent - class_dm_user.php

    Toronto Civic Club - Honda Civic ForumParse error: syntax error, unexpected '*', expecting '}' in /home/XXX/public_html/includes/class_dm_user.php(2941) : eval()'d code on line 15

    Unable to add cookies, header already sent.
    File: /home/XXX/public_html/includes/class_dm_user.php(2941) : eval()'d code
    Line: 15
    I have done the following to troubleshoot this

    disabled all pluggins via config
    tools.php, rebuilt datastore
    new style, non parented.
    re-uploaded all files again.


    (vBulletin 3.8.4)

    When I source what its calling for i see
    eval(fetch_email_phrases('welcomepm'));


    i checked the pluggins for the hook: welcomepm , nothing.

    At this point, i'm stuck. Any helps would be appreciated.


    And this all is steming from trying to get the Welcome PMs working.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X