Announcement

Collapse
No announcement yet.

Languages and Phrases are Completely Wrecked

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Languages and Phrases are Completely Wrecked

    Over the past couple of months I've tried to get help for this but to no avail. Now I know a little more about what's wrong so I'll try and explain it a bit better.

    My database corrupted a few months ago. Replacing the language table in the database with a 24 hour backup stopped the forums giving me a database error but some new problems developed over the next few days. If I tried to add a new profile field or infraction, the title for them would appear blank:



    I upgraded to the latest version of vBulletin and that seems to have made the problem worse. Activation emails only include the trailing "/register.php?a=act&u=148847&i=45885928" with the beginning of the domain missing and the subject just saying "Welcome to [blank space]" instead of "Welcome to Final Fantasy XIII Forums".

    I've also been told that this has started happening today:



    Looking into the phrase for this example I found this: "Thank you for logging in, $bbuserinfo[username]." This leads me to conclude that phrases are failing all over the entire forums and it's gradually getting worse. I've already re-uploaded the languages xml and rebuilt the languages but nothing is fixing it.

    Can anyone please please please help? I'm getting incredibly desperate here.

  • #2
    When you uploaded the languages, did you overwrite or create a new language?

    If the former, can you try adding a new one to see if this helps:

    AdminCP > Languages & Phrases > Language Manager > Add New Language
    Last edited by Trevor Hannant; Mon 1 Feb '10, 2:09pm.
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      I overwrote the default language. I just did it creating a new language but it's acting just the same.

      Comment


      • #4
        Sorry, I just clarified the post at the same time as you posted - did you create the new one via that method?
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          Yeah that's the way I did it

          Comment


          • #6
            Has anyone got anymore ideas?

            Comment


            • #7
              Can you raise a support ticket so we can look into this for you.
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                Originally posted by Trevor Hannant View Post
                Can you raise a support ticket so we can look into this for you.
                I sent one a while ago but I'll send another.

                Comment


                • #9
                  If you have already then it will be picked up as soon as possible - please don't raise another
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - "Quick Route" Interface...

                  Comment


                  • #10
                    Originally posted by Trevor Hannant View Post
                    If you have already then it will be picked up as soon as possible - please don't raise another
                    I sent the last one on the 19th January and after trying to fix it with tools.php, I was told to restore a backup from before I fixed my language table. My users have been documenting a walkthrough for a game during that period and I can't afford to lose any of it.

                    Comment


                    • #11
                      I'm sorry but to fix these would be to restore a backup either of the table itself (which you've already done) or the full site.

                      The other option is to find the missing phrases directly in your database via phpMyAdmin but this may take some time finding them all...
                      Vote for:

                      - *Admin Settable Paid Subscription Reminder Timeframe*
                      -
                      *PM - Add ability to reply to originator only*
                      - Add Admin ability to auto-subscribe users to specific channel(s)
                      - "Quick Route" Interface...

                      Comment


                      • #12
                        Originally posted by Trevor Hannant View Post
                        I'm sorry but to fix these would be to restore a backup either of the table itself (which you've already done) or the full site.

                        The other option is to find the missing phrases directly in your database via phpMyAdmin but this may take some time finding them all...
                        Well I can't help but think there's something else I can do. Phrases only seem to be dying in certain places. For example, $bbuserinfo[username] doesn't work in the "Thank you for Logging in" window like I showed in the screenshot above but it does work on this Welcome Header mod I have installed:



                        I checked to make sure and the phrase to make my username appear is definitely $bbuserinfo[username]. Why would it just stop working in certain places?

                        Comment


                        • #13
                          Have you tried seeing if the phrases work on a totally default style? Or if it could be a plugin problem?
                          Create a new style with no parent:
                          • Styles & Templates > Style Manager > Add New Style
                          • Parent Style: No Parent Style
                          • Title: Default vBulletin
                          • Allow User Selection: Yes
                          • Save


                          Then browse the site using that totally default vbulletin style - do you still have the same problem?

                          If it is still happening - Try disabling your modifications/plugins and see if you still have this problem.
                          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                          PHP Code:
                          define('DISABLE_HOOKS'true); 

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools &lt;- awesome site for html/css help

                          Comment


                          • #14
                            I've tried both a new style and disabling plugins before but I gave it another go. It's still the same :/

                            Comment


                            • #15
                              Are you using all default vbulletin php files? It's almost like the phrase group is not included in that particular page.

                              Please don't PM or VM me for support - I only help out in the threads.
                              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                              Want help modifying your vbulletin forum? Head on over to vbulletin.org
                              If I post CSS and you don't know where it goes, throw it into the additional.css template.

                              W3Schools &lt;- awesome site for html/css help

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X