Announcement

Collapse
No announcement yet.

Forum too slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forum too slow

    Hi there,

    Few of our users are complaining about forum being a tad too slow at times. At times when they post, it times out. Page loading too is very slow. My rough guess is that about 30% of the users are facing this problem - and they are not from just one part of the world. One particular user isn't able to post any posting longer than 2-3 words.

    My guess is that it is a host/server issue - is there any good way I can test the server? We're on shared hosting. We had some downtime few weeks ago too so that's why I'm suspect of the host.

    If not host/server issue, what else could it be? I have turned off add-ons that we don't use but that hasn't made much difference.

    Thanks in advance

    Arsh

  • #2
    Because you are on a shared host that's your problem..... It's their servers playing up because they can't handle the amount of traffic causing your forum to be slow

    Only solution is to change to a host that doesn't use shared servers.
    Aussiefootyforums

    New Site New forum
    Come and talk sports all day long


    Comment


    • #3
      Originally posted by schwab2clarkson View Post
      Because you are on a shared host that's your problem..... It's their servers playing up because they can't handle the amount of traffic causing your forum to be slow

      Only solution is to change to a host that doesn't use shared servers.
      Thanks mate. But if it was really the server, wouldn't all the users be having the problem? Only some users are consistently having the problem.

      Comment


      • #4
        Hi Arsh -

        Log into the server (shell) and type 'top' in - then hit the 1 key - it will show you the server stats and you can update the refresh rate (d) - q to quit

        At least that will tell you if it is indeed a slowdown due to load on the server -

        best regards -

        mqqn

        Comment


        • #5
          Originally posted by mqqn View Post
          Hi Arsh -

          Log into the server (shell) and type 'top' in - then hit the 1 key - it will show you the server stats and you can update the refresh rate (d) - q to quit

          At least that will tell you if it is indeed a slowdown due to load on the server -

          best regards -

          mqqn
          Thanks. I'm really naive at this stuff but I logged in to shell server using puTTY but command 'top' isn't working. I get

          -bash: top: command not found

          Comment


          • #6
            Hi Arsh -

            I log into my host using putty, ssh, and as soon as I get the command prompt I enter the top command -

            Perhaps you need to ask your hosting support about that command - perhaps it is disabled?

            Here is what I see when I do that command -

            top - 19:34:21 up 60 days, 19:29, 1 user, load average: 5.32, 5.57, 5.49
            Mem: 8285720k total, 7994148k used, 291572k free, 295036k buffers
            Swap: 8385848k total, 8196k used, 8377652k free, 5220740k cached

            PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
            31885 mysql 20 0 1064m 956m 5376 S 17.8 11.8 3847:58 mysqld
            14715 root 39 19 0 0 0 S 0.6 0.0 304:12.44 kipmi0
            8402 root 20 0 135m 7168 3588 S 0.0 0.1 135:47.90 dsm_sa_datamgr3
            4115 root 15 -5 0 0 0 S 0.3 0.0 89:08.76 kjournald
            8908 root 20 0 220m 24m 5984 S 0.0 0.3 78:51.78 dsm_om_connsvc3
            14893 root 5 -15 5956 2452 1352 S 0.0 0.0 75:33.93 hostmon-client
            30341 dovecot 20 0 4628 2392 1232 S 0.0 0.0 53:54.15 pop3-login
            30340 dovecot 20 0 4176 2048 1224 S 0.0 0.0 50:34.29 pop3-login
            4112 root 15 -5 0 0 0 S 0.0 0.0 43:06.78 kjournald
            30299 root 20 0 3300 2000 748 S 0.0 0.0 39:49.65 dovecot-auth
            30297 root 20 0 1892 652 420 S 0.0 0.0 35:48.14 dovecot
            10 root 15 -5 0 0 0 S 0.0 0.0 32:06.66 ksoftirqd/2
            13 root 15 -5 0 0 0 S 0.0 0.0 30:09.95 ksoftirqd/3
            239 root 15 -5 0 0 0 S 0.0 0.0 27:04.98 kswapd0
            4 root 15 -5 0 0 0 S 0.0 0.0 26:49.24 ksoftirqd/0
            7 root 15 -5 0 0 0 S 0.0 0.0 26:40.86 ksoftirqd/1
            32748 root 20 0 126m 124m 1808 S 0.6 1.5 25:28.04 tailwatchd
            8940 root 20 0 4696 2672 1284 S 0.0 0.0 21:50.43 hald
            14406 root 20 0 1720 832 608 S 0.0 0.0 18:06.87 syslogd

            I hope this helps you -

            best regards -

            mqqn

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X