Announcement

Collapse
No announcement yet.

Database Error: Unable to connect to the database:Could not connect to MySQL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Error: Unable to connect to the database:Could not connect to MySQL

    A little background, I am hosted by justhost.com and a sever my account was on just died. They had to rebuild it and restore everything from the last backup they had. Everything has been restored and I noticed things didnt work. There was no account for the database for some reason so I created a new mysql account and attached it to that database - added the information to the config.php and got started.

    Everytime I try to log in, I get the error

    Database Error: Unable to connect to the database:Could not connect to MySQL

    Funny thing is, my information is cookied on my itouch and the forum works from there because I dont have to log in. I can post and do whatever, I just cant do it from my laptop. Some of our users are back online and posting, probably because they are cached. Doesn't make sense to me, any ideas?

    Thanks for any help I can get.

  • #2
    try clearing your cookies.

    Comment


    • #3
      Originally posted by scylla22 View Post
      try clearing your cookies.
      Done that and all database, user and pw are correct in the config.php

      Comment


      • #4
        did you try going to it with a different browser?

        Comment


        • #5
          Originally posted by scylla22 View Post
          did you try going to it with a different browser?
          Yeah I just tried it in IE right now because I never use it and same thing...

          Comment


          • #6
            well from your itouch try going to the admin cp then, repair and optimize tables and try again.

            Comment


            • #7
              Originally posted by scylla22 View Post
              well from your itouch try going to the admin cp then, repair and optimize tables and try again.
              admincp always forces you to login again, so I cant access anything other than the forums.

              Comment


              • #8
                Can you access phpmyadmin? If so you can run those same checks from there.

                Comment


                • #9
                  So one of my users just pm'd me a way around it. If you put in your name + password and check the remember me box, you get the error but if you reload the main page your logged in.

                  This is really weird.

                  Comment


                  • #10
                    Originally posted by scylla22 View Post
                    Can you access phpmyadmin? If so you can run those same checks from there.
                    yes, just not sure how...

                    thanks for all the help, i really appreciate it.

                    Comment


                    • #11
                      Just repaired my tables with phpmyadmin, everything shows as OK but still getting the error trying to log in for everyone.

                      Anyone have any other advice?

                      Comment


                      • #12
                        That happens with too many connections on the server. lol i never had that problem with JustHost when i had my gaming site up and running.
                        Probably best to ask JustHost support about the problem. It has nothing to do with browsers or cookies, its your server.

                        Comment


                        • #13
                          Originally posted by Ak Worm View Post
                          That happens with too many connections on the server. lol i never had that problem with JustHost when i had my gaming site up and running.
                          Probably best to ask JustHost support about the problem. It has nothing to do with browsers or cookies, its your server.
                          I have talked with them and they seem to think everything is in working order. The database is up and I can connect to it (obviously with being able to post, etc), it is only during logging in and logging out it does this error.

                          Comment


                          • #14
                            How can I access my products / plugins without being able to login to cpanel? I think it may be a JFusion plugin that is causing this error.

                            Comment


                            • #15
                              This problem was created by the following issue. JFusion plugin was trying to sync w/ Joomla however Joomla was not online due to the user missing from the jconfig. Thank you everyone for your help.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X