Announcement

Collapse
No announcement yet.

Your submission could not be processed because a security token was missing.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Your submission could not be processed because a security token was missing.

    Got that error when I try to use the search function on my forums: forum.theclubpenguincheats.com
    I Manually editted a ton of the template code so I dont want to "revert it to default' or anything like that.
    Help what do I do?

  • #2
    In your templates, find where you have your form. Above the button, add this code:

    Code:
    <input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />
    Adam

    Admin of PentaxForums.com, premiere photography forum for Pentax users (Big-Board).

    Comment


    • #3
      Sorry for being a noob but what do you mean form? which one?

      Comment


      • #4
        Any form submitted needs to have that code. This includes the search feature, login area, and sorting options.

        In your templates, find any ocurrence of <form.....>. Before the </form> tag, the code I posted above has to be present.
        Adam

        Admin of PentaxForums.com, premiere photography forum for Pentax users (Big-Board).

        Comment


        • #5
          Um, thats a whole lot of templates Ill have to search myself and edit... Are you sure this will work and can you be a little more specific? I mean dont I just need to do the search templates?

          Comment


          • #6
            Edit: I looked at all the search templates. The ones with form already have that added..

            Comment


            • #7
              Look in your navbar or header and see if the search dropdown has it.

              What pages exactly give you the token error?
              Adam

              Admin of PentaxForums.com, premiere photography forum for Pentax users (Big-Board).

              Comment


              • #8
                Originally posted by MoMan View Post
                Look in your navbar or header and see if the search dropdown has it.

                What pages exactly give you the token error?
                I dont know. The only thing that comes up when I use the search button is the missing token message.

                Comment


                • #9
                  I think I found the problem. This is my navbar template. Do I need to change/add anything:

                  <br />

                  <!-- breadcrumb, login, pm info -->
                  <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
                  <tr>
                  <td class="alt1" width="100%">
                  <if condition="is_array($navbits)">
                  <table cellpadding="0" cellspacing="0" border="0">
                  <tr valign="bottom">
                  <td><a href="#" onclick="history.back(1); return false;"><img src="$stylevar[imgdir_misc]/navbits_start.gif" alt="$vbphrase[go_back]" border="0" /></a></td>
                  <td>&nbsp;</td>
                  <td width="100%"><span class="navbar"><a href="$vboptions[forumhome].php$session[sessionurl_q]" accesskey="1">$vboptions[bbtitle]</a></span> $navbits[breadcrumb]</td>
                  </tr>
                  <tr>
                  <td class="navbar" style="font-size:10pt; padding-top:1px" colspan="3"><if condition="$_SERVER['REQUEST_METHOD'] == 'POST'"><img class="inlineimg" src="$stylevar[imgdir_misc]/navbits_finallink_$stylevar[textdirection].gif" alt="" border="0" /><else /><a href="$scriptpath"><img class="inlineimg" src="$stylevar[imgdir_misc]/navbits_finallink_$stylevar[textdirection].gif" alt="$vbphrase[reload_this_page]" border="0" /></a></if> <strong>$navbits[lastelement]</strong></td>
                  </tr>
                  </table>
                  <else />
                  <div class="navbar" style="font-size:10pt"><a href="$vboptions[forumhome].php$session[sessionurl_q]" accesskey="1"><img class="inlineimg" src="$stylevar[imgdir_misc]/navbits_start.gif" alt="" border="0" /></a> <strong>$vboptions[bbtitle]</strong></div>
                  </if>
                  </td>

                  <if condition="$show['member']">

                  <td class="alt2" valign="top" nowrap="nowrap">
                  <div class="smallfont">
                  <strong><phrase 1="$bbuserinfo[username]">$vbphrase[welcome_x]</phrase></strong><br />
                  <phrase 1="$pmbox[lastvisitdate]" 2="$pmbox[lastvisittime]">$vbphrase[last_visited_x_at_y]</phrase>
                  <if condition="$show['pmstats']"><br /><phrase 1="$vbphrase[unread_x_nav_compiled]" 2="$vbphrase[total_x_nav_compiled]" 3="$session[sessionurl_q]">$vbphrase[private_messages_nav]</phrase></if>
                  <if condition="$show['pmwarning']"><br /><strong><phrase 1="$vbphrase[pmpercent_nav_compiled]">$vbphrase[your_pm_box_is_x_full]</phrase></strong></if>
                  </div>
                  </td>

                  <else />

                  <td class="alt2" nowrap="nowrap" style="padding:0px">

                  <!-- login form -->
                  <form action="login.php?do=login" method="post" onsubmit="md5hash(vb_login_password, vb_login_md5password, vb_login_md5password_utf, $show[nopasswordempty])">
                  <script type="text/javascript" src="clientscript/vbulletin_md5.js?v=$vboptions[simpleversion]"></script>
                  <table cellpadding="0" cellspacing="$stylevar[formspacer]" border="0">
                  <tr>
                  <td class="smallfont"><label for="navbar_username">$vbphrase[username]</label></td>
                  <td><input type="text" class="bginput" style="font-size: 11px" name="vb_login_username" id="navbar_username" size="10" accesskey="u" tabindex="101" value="$vbphrase[username]" onfocus="if (this.value == '$vbphrase[username]') this.value = '';" /></td>
                  <td class="smallfont" colspan="2" nowrap="nowrap"><label for="cb_cookieuser_navbar"><input type="checkbox" name="cookieuser" value="1" tabindex="103" id="cb_cookieuser_navbar" accesskey="c" />$vbphrase[remember_me]</label></td>
                  </tr>
                  <tr>
                  <td class="smallfont"><label for="navbar_password">$vbphrase[password]</label></td>
                  <td><input type="password" class="bginput" style="font-size: 11px" name="vb_login_password" id="navbar_password" size="10" tabindex="102" /></td>
                  <td><input type="submit" class="button" value="$vbphrase[log_in]" tabindex="104" title="$vbphrase[enter_username_to_login_or_register]" accesskey="s" /></td>
                  </tr>
                  </table>
                  <input type="hidden" name="s" value="$session[sessionhash]" />
                  <input type="hidden" name="do" value="login" />
                  <input type="hidden" name="vb_login_md5password" />
                  <input type="hidden" name="vb_login_md5password_utf" />
                  </form>
                  <!-- / login form -->

                  </td>

                  </if>

                  </tr>
                  </table>
                  <!-- / breadcrumb, login, pm info -->

                  <!-- nav buttons bar -->
                  <!-- / nav buttons bar -->

                  <br />
                  <if condition="$show['forumdesc']">
                  <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
                  <tr>
                  <td class="alt1" width="100%"><strong>$foruminfo[title]</strong> <span class="smallfont">$foruminfo[description]</span></td>
                  </tr>
                  </table>
                  <br />
                  </if>

                  <if condition="$show['popups']">
                  <!-- NAVBAR POPUP MENUS -->

                  <if condition="$show['searchbuttons']">
                  <!-- header quick search form -->
                  <div class="vbmenu_popup" id="navbar_search_menu" style="display:none">
                  <table cellpadding="4" cellspacing="1" border="0">
                  <tr>
                  <td class="thead">$vbphrase[search_forums]</td>
                  </tr>
                  <tr>
                  <td class="vbmenu_option" title="nohilite">
                  <form action="search.php?do=process" method="post">
                  <input type="hidden" name="do" value="process" />
                  <input type="hidden" name="quicksearch" value="1" />
                  <input type="hidden" name="childforums" value="1" />
                  <input type="hidden" name="exactname" value="1" />
                  <input type="hidden" name="s" value="$session[sessionhash]" />
                  <div><input type="text" class="bginput" name="query" size="25" tabindex="1001" /><input type="submit" class="button" value="$vbphrase[go]" tabindex="1004" /></div>
                  <div style="margin-top:$stylevar[cellpadding]px">
                  <label for="rb_nb_sp0"><input type="radio" name="showposts" value="0" id="rb_nb_sp0" tabindex="1002" checked="checked" />$vbphrase[show_threads]</label>
                  &nbsp;
                  <label for="rb_nb_sp1"><input type="radio" name="showposts" value="1" id="rb_nb_sp1" tabindex="1003" />$vbphrase[show_posts]</label>
                  </div>
                  </form>
                  </td>
                  </tr>
                  <tr>
                  <td class="vbmenu_option"><a href="search.php$session[sessionurl_q]" accesskey="4" rel="nofollow">$vbphrase[advanced_search]</a></td>
                  </tr>
                  $template_hook[navbar_search_menu]
                  </table>
                  </div>
                  <!-- / header quick search form -->
                  </if>

                  <if condition="$show['member']">
                  <!-- user cp tools menu -->
                  <div class="vbmenu_popup" id="usercptools_menu" style="display:none">
                  <table cellpadding="4" cellspacing="1" border="0">

                  <tr><td class="thead">$vbphrase[quick_links]</td></tr>
                  <if condition="$vboptions['enablesearches']"><tr><td class="vbmenu_option"><a href="search.php?$session[sessionurl]do=getdaily">$vbphrase[todays_posts]</a></td></tr></if>
                  <tr><td class="vbmenu_option"><a href="forumdisplay.php?$session[sessionurl]do=markread">$vbphrase[mark_forums_read]</a></td></tr>
                  <tr><td class="vbmenu_option"><a href="#" onclick="window.open('misc.php?$session[sessionurl]do=buddylist&amp;focus=1','buddylist','statusbar=no,menubar=no,toolbar=no,scrollbars=yes,r esizable=yes,width=250,height=300'); return false;">$vbphrase[open_buddy_list]</a></td></tr>
                  $template_hook[navbar_quick_links_menu_pos1]

                  <tr><td class="thead"><a href="usercp.php$session[sessionurl_q]">$vbphrase[user_control_panel]$cyb_paypal_donate_link</a></td></tr>
                  <if condition="$show['siglink']"><tr><td class="vbmenu_option"><a href="profile.php?$session[sessionurl]do=editsignature">$vbphrase[edit_signature]</a></td></tr></if>
                  <!--<if condition="$show['avatarlink']"><tr><td class="vbmenu_option"><a href="profile.php?$session[sessionurl]do=editavatar">$vbphrase[edit_avatar]</a></td></tr></if>-->
                  <tr><td class="vbmenu_option"><a href="profile.php?$session[sessionurl]do=editprofile">$vbphrase[edit_profile]</a></td></tr>
                  <tr><td class="vbmenu_option"><a href="profile.php?$session[sessionurl]do=editoptions">$vbphrase[edit_options]</a></td></tr>
                  $template_hook[navbar_quick_links_menu_pos2]

                  <tr><td class="thead">$vbphrase[miscellaneous]</td></tr>
                  <if condition="$show['pmmainlink']"><tr><td class="vbmenu_option"><a href="private.php$session[sessionurl_q]" rel="nofollow">$vbphrase[private_messages]</a></td></tr></if>
                  <tr><td class="vbmenu_option"><a href="subscription.php$session[sessionurl_q]" rel="nofollow">$vbphrase[subscribed_threads]</a></td></tr>
                  <tr><td class="vbmenu_option"><a href="member.php?$session[sessionurl]u=$bbuserinfo[userid]">$vbphrase[my_profile]</a></td></tr>
                  <if condition="$show['wollink']"><tr><td class="vbmenu_option"><a href="online.php$session[sessionurl_q]">$vbphrase[whos_online]</a></td></tr></if>
                  $template_hook[navbar_quick_links_menu_pos3]

                  </table>
                  </div>
                  <!-- / user cp tools menu -->
                  </if>
                  <!-- / NAVBAR POPUP MENUS -->

                  <!-- PAGENAV POPUP -->

                  <div class="vbmenu_popup" id="pagenav_menu" style="display:none">
                  <table cellpadding="4" cellspacing="1" border="0">
                  <tr>
                  <td class="thead" nowrap="nowrap">$vbphrase[go_to_page]</td>
                  </tr>
                  <tr>
                  <td class="vbmenu_option" title="nohilite">
                  <form action="$vboptions[forumhome].php" method="get" onsubmit="return this.gotopage()" id="pagenav_form">
                  <input type="text" class="bginput" id="pagenav_itxt" style="font-size:11px" size="4" />
                  <input type="button" class="button" id="pagenav_ibtn" value="$vbphrase[go]" />
                  </form>
                  </td>
                  </tr>
                  </table>
                  </div>

                  <!-- / PAGENAV POPUP -->
                  </if>

                  Comment


                  • #10
                    I tried reverting the navbar. But it completely messed up my site (it added a 2nd gray, nav bar UNDER the username part and the original red navbar above it was still there above the username part)

                    Comment


                    • #11
                      Add it in the header template.
                      Shamil Nunhuck, - Radon Systems Ltd.
                      VPS + Dedicated Server Hosting and Management
                      vBulletin Hosting and Services
                      Server / Website Consultation

                      Comment


                      • #12
                        I searched for the word 'form' in header template and I couldnt find it
                        P.S. do I add this right about the form portion?

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X