Announcement

Collapse
No announcement yet.

vBulletin Download is bugged.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin Download is bugged.

    Version 3.8.4 is bugged the config.php.new file contains the following:

    Code:
    $config['MasterServer']['servername'] = 'localhost';
    $config['MasterServer']['port'] = 3306;
    Instead of this

    Code:
    $config['MasterServer']['servername'] = 'localhost';
    $config['MasterServer']['port'] = '3306';
    It wasn't working correctly when I installed it, and it took my host an hour to track down why it was messing up their server setup.

  • #2
    Pretty sure that shouldn't matter. Its working fine on most of my installs.

    Comment


    • #3
      Well then explain to me why my forum wouldn't install, and after an hour the admin made that one change, refreshed the page and it started working.

      And you even said that its working on most of your installs, so if must not be working on the rest? I'm not sure why it effected my host, but something in their setup didn't like that.

      Edit: I tested it by putting the line back the way it was, and my forum went down again all I get is a page that says "Database Error". Put them back and it works fine.

      Comment


      • #4
        What is the database error? well If it was truely bugged, more than just you would be having issues don't you think?

        Comment


        • #5
          Guess I really don't care, its your name on the software, not mine. Guess only professionals care about syntax errors. No wonder there are 10,000 bugs in the CMS. You can't even admit when you guys screw up, you just point out other companies like in your announcement boards when your manager says "but, look at Apache, and Java, look at all their errors, see they suck too". I've never seen a company justify their mistakes by turning the blame to other companies.

          http://www.vbulletin.com/forum/showt...coming-vB4-RC1
          To put this in perspective, some of the most widely used software in the world runs in millions of production sites despite having queues of hundreds or thousands of minor bugs. For example, see the bug trackers for Java and Apache.
          Nice way to justify your mistakes, try to turn peoples attention to another company. I wonder how those companies would feel reading that post.

          VERY PROFESSIONAL!

          Comment


          • #6
            Uploading files not in binary mode can cause such error.
            ...... sigpic ...... "А стукачков мы не любим!"

            My Modification: Quote Post in PM - passes to new personal message (PM) post's text, username, etc.

            Comment


            • #7
              Originally posted by Makc666 View Post
              Uploading files not in binary mode can cause such error.
              Yep, and they clearly have a syntax error in that code. That should be enclosed in single quotes. I don't know of any professional programmer that would say that is "OK". Thats like saying leave off your closing tags in HTML, they will still work. Yea, they will, most of the time.

              Something in my host setup doesn't like that value because the syntax is incorrect. I use the largest web host in the world hosting over 6.5 million domain names. The Admin there should have somewhat of an idea what he's talking about. He researched for an hour and found that to be the problem. But, I guess hes just a moron. Not sure how he got the be the Admin of the largest web host in the world.

              Also, a bug is something that you can replicate. If you can remove the quotes and it stops working, put them back and it starts working again, there is something fishy about that. It doesn't matter how many people find the bug, a bug is a bug. Some people don't realize that. Its a simple fix most people probably just add them and don't bother making a ticket.

              Comment


              • #8
                Put it in the bug tracker if you think it's a bug.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools <- awesome site for html/css help

                Comment


                • #9
                  GoDaddy? Godaddy has a pretty horrible track record as a webhost.

                  Lynne is correct though, if you believe the issue to be a bug, bug report it. I'm only tech support. Though in my many years of being a member of this community and providing support for vBulletin, this would be a first time that has cause an issue.

                  Comment


                  • #10
                    Just an FYI but I don't have my port in quotes and I have never had a problem on any of the servers I have hosted on.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools <- awesome site for html/css help

                    Comment


                    • #11
                      Originally posted by Lynne View Post
                      Just an FYI but I don't have my port in quotes and I have never had a problem on any of the servers I have hosted on.
                      Ditto, x5.

                      By default, config.php.new doesn't have quotes around any of the database ports.

                      If this truly were an issue with most setups, I'd have to wonder why this is the first time I have ever seen it reported.
                      My Live vB5 Site - NZEating.com
                      vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

                      Comment


                      • #12
                        port doesn't need quotes, it's an integer, not a string.

                        servername does because it is a string.

                        It's not a bug and mine is as shown above and has worked fine for many years across numerous different servers.
                        MARK.B | vBULLETIN SUPPORT

                        TalkNewsUK - My vBulletin 5.6.3 Demo
                        AdminAmmo - My Cloud Demo

                        Comment


                        • #13
                          7 and a half years running versions from vB2 through to vB4 with several different hosting companies and I've never had that problem either.
                          Vote for:

                          - *Admin Settable Paid Subscription Reminder Timeframe*
                          -
                          *PM - Add ability to reply to originator only*
                          - Add Admin ability to auto-subscribe users to specific channel(s)
                          - "Quick Route" Interface...

                          Comment


                          • #14
                            Technically if you put the quotes in it's incorrect as the number is then a string, though in practice php shouldn't have any difficulty with that.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.6.3 Demo
                            AdminAmmo - My Cloud Demo

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X