Announcement

Collapse
No announcement yet.

Database error issues / wrong email

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Orp
    replied
    Thanks for the reply Wayne.
    I did find the setting in my config.php file, finally.

    I do run my own server. I am my own ISP.

    I changed the server wide settings recommended by mysql, and suggested early on this this thread (with the link). I added:

    /etc/sysctl.conf: # Increase some values for MySQL
    fs.file-max = 65536
    fs.dquot-max = 8192
    fs.super-max = 1024
    NOTE: after editing the sysctl.conf file you must run sysctl -p to have the new values read in.

    You should also add the following to /etc/my.cnf:
    [mysqld_safe]
    open-files-limit=8192
    -------------------------------
    Question:
    Do I need to restart mysqld for the my.cnf setting to take affect?
    If so, do I have to stop all VB databases before stopping and restarting mysqld?

    Leave a comment:


  • Wayne Luke
    replied
    The email address for database errors is located in your config.php file under Technical Email.

    For the too many connections error, this is a server wide setting. If you are on shared hosting, it might not even be your site that triggers the error. If you have your own server, you may have your backup script put in a static maintenance page that doesn't hit your database for information. This would lower the chance of the error occurring if your site happens to be busy when to start the backup.

    Leave a comment:


  • Orp
    replied
    No 3rd party stuff. Here is the command I use:

    /usr/bin/mysqldump --opt -Q -u ******* -p****** forumsforums > /home/*******/bkup_1.sql

    **'s replace site specific stuff, otherwise this is how the mysqldump runs.

    Leave a comment:


  • Trevor Hannant
    replied
    What do you use for the backup? Is it 3rd party software?

    Leave a comment:


  • Orp
    replied
    After making the changes shown in the previous post I'm still gettting the Database error message saying:

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too
    many connections
    ...../includes/class_core.php on line 311

    I only get these errors at 4am when I am backing up the database. No other time.
    Every day during the db backup I get these errors.
    Any ideas on why I get the errors during the backup only, and what I can do to fix it?

    Leave a comment:


  • Orp
    replied
    Followup. Guess there is no mysql.conf or mysqld.conf file.
    From the link trevor provided in the 2nd post I found the following info and tried adding that to my OS (centOS):

    /etc/sysctl.conf: # Increase some values for MySQL
    fs.file-max = 65536
    fs.dquot-max = 8192
    fs.super-max = 1024
    NOTE: after editing the sysctl.conf file you must run sysctl -p to have the new values read in.

    You should also add the following to /etc/my.cnf:
    [mysqld_safe]
    open-files-limit=8192

    Two of the values would not take. Both
    fs.dquot-max = 8192 and
    fs.super-max = 1024
    were not recognized by the kernel. I left the other settings in place and am hoping for the best.
    Will update this ticket if this does not fix my problem of running out of DB connections.

    Leave a comment:


  • Orp
    replied
    I finally found the persistent connections setting (in my config.php file DUH) and it is already turned off.
    Any pointers on where to find the setting for up'ing mysql connections?

    edit to add:
    max connections should be in the mysql.conf file ....right?

    Leave a comment:


  • Orp
    replied
    No, DUH, Stupid me. THAT WAS IT!!!! Thank You sir!!!!! It had been driving me bonkers.
    I appreciate all your help!!!!!!!!

    I would give you more reps but they want me to spread it around more first.

    Leave a comment:


  • Trevor Hannant
    replied
    Doh!! Stupid me...

    What's in the config.php file:

    $config['Database']['technicalemail']

    Leave a comment:


  • Orp
    replied
    Thanks again Trevor but the site contact in that area is correct. Still I get these messges sent to webmaster .....chm instead of com.

    That section of VB options does also mention sendmessage.php and I checked that for having the wrong address inside of it (per chance) and it is not there.
    I've grep'd all files in my forums and have not found any that have the [email protected] address. So it has be baffled.
    Any other ideas?

    (note: I hate where the previous thread /next thread buttons are, as they are where submit post/post reply used to be in 3.x ...VB 4.0 is going to take some getting used to)

    Leave a comment:


  • Trevor Hannant
    replied
    From my first post:

    AdminCP > vBulletin Options > Site Name / URL / Contact Details

    Leave a comment:


  • Orp
    replied
    Thanks Trevor. Sounds like an easy fix with no down side.

    Any clue on how I might track down where I typo'd the email address to be notifed of database errors?

    Leave a comment:


  • Trevor Hannant
    replied
    All persistant connections do is take up system resources when they aren't needed. With persistant connections off, the database connection is released once a forum page is finished loading. With persistant connections on, the connection is maintained.

    Leave a comment:


  • Orp
    replied
    Thanks Trevster. I didn't see your reply until after I had posted my above reply with more info. Your reply confirms my fear that it is partially a system issue. I am my own host ... so I'll have to find that particular setting on how to up the connections. I have plenty of resourse available. No other performance issues.

    The other forum that I got the to many connections on is not busy in the least, and it was not being backed up. So, does backing up the DB normally open a lot of connections to the database?
    What would be the affect of turning off persistent connections?

    Leave a comment:


  • Orp
    replied
    I have a little more info that might help ...or confuse the issue.
    I have a backup script that backs up all the VB databases at 4am. It backs up one DB, sleeps for 15 seconds thens starts backup up the next DB in line. During the backup of Forums Forums, the VB database listed in the 1st post, I got an email saying one of the other databases had the exact same too many connections error and it referenced the same line of code as mentioned in the error message in the 1st post (line 311). I thought the backup was at issue, but perhaps that is not the case.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X