Announcement

Collapse
No announcement yet.

Odd problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Odd problem

    I'm pounding my head against a wall on this one.

    I've got a few users who are wanting to send up 10-60mb PDF files, and where I can send them up fine, when anyone tries to download them, they get a "could not be saved, because the source file could not be read."

    This error only appears on files over 10Mb.

    I'm stumped, and my research isn't finding anything.

  • #2
    Are the attachments stored in the database or the file system?

    Here are some different settings you may want to look at that effect your attachments:
    PHP Settings:
    max_execution_time
    memory_limit
    post_max_size
    upload_max_filesize
    max_input_time

    MySQL Settings:
    max_allowed_packet
    max_packet_size
    wait_timeout

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Originally posted by Lynne View Post
      Are thmze attachments stored in the database or the file system?
      Here are some different settings you may want to look at that effect your attachments:
      PHP Settings:
      max_execution_time = 3000
      memory_limit = 768M
      post_max_size = 768M
      upload_max_filesize = 768M
      max_input_time = 3600

      MySQL Settings:
      max_allowed_packet = 768M
      max_packet_size = n/a
      wait_timeout = n/a
      They're stored in the database. The items with n/a did not have an entry.


      Also - Should I look into the default_socket_timeout entry?

      Comment


      • #4
        Lynne - Any thoughts?

        Comment


        • #5
          Unfortunately, that is not my area of expertise. I don't like making recommendations on changing settings on the server (I find servers to be very tempermental and non-likeable!). Since they are stored in the database, I would guess it is a mysql setting that you want to tweek, but I'm not sure which one (I know I have had to play with my wait_timeout at times for larger files - I currently have mine set at 480, I think). Hopefully Steve or Wayne will come along and I'm sure they can help out.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Fair enough, thanks!

            Comment


            • #7
              Honestly, PHP/MySQL was not made to accommodate such large uploads. Howevewr here's the generic spiel:

              In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

              upload_max_filesize = xM

              ..and my.cnf (or my.ini for Windows systems)

              set-variable=max_allowed_packet=xM

              Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

              Note: Do NOT use MB, just M for the megabytes setting.

              You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.

              Also you might want to take a look at this for other settings that affect file uploads:

              http://www.vbulletin.com/forum/showp...0&postcount=12
              http://www.vbulletin.com/forum/showt...319#post748319
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Fair enough, I've got all those set (see above in bold) except for the max_packet_size. Is that the same as the max_allowed_packet?

                Also, is it possible to have it set too high?

                Oh, and just to point out.

                It's not uploading files that's the problem, it's downloading. It gets to about 10M, and just dies.

                Error I'm getting:

                filename could not be saved, because the source file could not be read.
                Last edited by Pope Viper; Sat 14 Nov '09, 6:20pm.

                Comment


                • #9
                  That looks like either a bad file or the server timed out before it could read it.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X