Announcement

Collapse
No announcement yet.

My site is being moved to another server /problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • My site is being moved to another server /problem

    Hi,

    My home page being http://174.120.171.227/~newage/ is blank except for below info:

    Can someone tell me how I would fix this.

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/index.php(596) : eval()'d code on line 14

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/index.php(597) : eval()'d code on line 27

  • #2
    Hi,

    Found this link http://www.vbulletin.com/forum/showt...er-PLEASE-HELP and made change to config.php to include define('DISABLE_HOOKS', true);

    on config.php right at the beginning of file after <?php

    And now I get a data base error . so I took out the ('DISABLE_HOOKS', true); .

    But that did not make a difference.

    Please help

    Originally posted by New Age View Post
    Hi,

    My home page being http://174.120.171.227/~newage/ is blank except for below info:

    Can someone tell me how I would fix this.

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/includes/functions_forumlist.php(393) : eval()'d code on line 18

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/index.php(596) : eval()'d code on line 14

    Parse error: syntax error, unexpected '=' in /home/newage/public_html/index.php(597) : eval()'d code on line 27

    Comment


    • #3
      eval()'d code errors more often than not relate to plugins you have running. I've just tried to access the new site and gotten the following error:

      Code:
      Database error in vBulletin :
       
      mysql_connect() [&lt;a href='function.mysql-connect'&gt;function.mysql-connect&lt;/a&gt;]: Access denied for user [EMAIL="'spirit'@'localhost'"]'spirit'@'localhost'[/EMAIL] (using password: YES)
      /home/newage/public_html/includes/class_core.php on line 311
       
      MySQL Error   : 
      Error Number  : 
      Request Date  : Wednesday, November 11th 2009 @ 03:13:04 AM
      Error Date    : Wednesday, November 11th 2009 @ 03:13:04 AM
      Script        : [URL]http://174.120.171.227/~newage/[/URL]
      Referrer      : [URL]http://www.vbulletin.com/forum/showthread.php?324876-My-site-is-being-moved-to-another-server-problem[/URL]
      IP Address    : 86.132.167.120
      Username      : 
      Classname     : vB_Database
      MySQL Version :
      Try disabling them all via AdminCP then turning each one on in turn until you find the error.

      As a side note, have you updated AdminCP > vBulletin Options > Site Name / URL / Contact Details?
      Vote for:

      - *Admin Settable Paid Subscription Reminder Timeframe*
      -
      *PM - Add ability to reply to originator only*
      - Add Admin ability to auto-subscribe users to specific channel(s)
      - "Quick Route" Interface...

      Comment


      • #4
        Hello,

        I get the same message when I try to get to my admin which is http://174.120.171.227/~newage/admincp/

        Anyone know how I can get this sorted.


        Originally posted by Trevster View Post
        eval()'d code errors more often than not relate to plugins you have running. I've just tried to access the new site and gotten the following error:

        Code:
        Database error in vBulletin :
         
        mysql_connect() [&lt;a href='function.mysql-connect'&gt;function.mysql-connect&lt;/a&gt;]: Access denied for user 'spirit'@'localhost' (using password: YES)
        /home/newage/public_html/includes/class_core.php on line 311
         
        MySQL Error   : 
        Error Number  : 
        Request Date  : Wednesday, November 11th 2009 @ 03:13:04 AM
        Error Date    : Wednesday, November 11th 2009 @ 03:13:04 AM
        Script        : [URL]http://174.120.171.227/~newage/[/URL]
        Referrer      : [URL]http://www.vbulletin.com/forum/showthread.php?324876-My-site-is-being-moved-to-another-server-problem[/URL]
        IP Address    : 86.132.167.120
        Username      : 
        Classname     : vB_Database
        MySQL Version :
        Try disabling them all via AdminCP then turning each one on in turn until you find the error.

        As a side note, have you updated AdminCP > vBulletin Options > Site Name / URL / Contact Details?

        Comment


        • #5
          "Access denied for user 'spirit'@'localhost' " means a problem with the username/password combination in your config.php file or the user doesn't have the correct privileges on the database itself.

          You'll need to contact your host regarding that part.
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - "Quick Route" Interface...

          Comment


          • #6
            Thankyou,

            I will be back.

            Originally posted by Trevster View Post
            "Access denied for user 'spirit'@'localhost' " means a problem with the username/password combination in your config.php file or the user doesn't have the correct privileges on the database itself.

            You'll need to contact your host regarding that part.

            Comment


            • #7
              Originally posted by New Age View Post
              Thankyou,

              I will be back.
              Im Back.

              Okay now when I try to login here http://174.120.171.227/~newage/admincp/

              I get the below.

              Please help

              Parse error: syntax error, unexpected '=' in /home/newage/public_html/global.php(607) : eval()'d code(255) : eval()'d code on line 17

              Parse error: syntax error, unexpected '=' in /home/newage/public_html/global.php(1091) : eval()'d code(21) : eval()'d code on line 1

              Parse error: syntax error, unexpected '=' in /home/newage/public_html/global.php(1091) : eval()'d code(22) : eval()'d code on line 4

              Parse error: syntax error, unexpected '=' in /home/newage/public_html/global.php(1091) : eval()'d code(25) : eval()'d code on line 17

              <H4>vBulletin Message


              </H4>
              Unable to add cookies, header already sent.

              File: /home/newage/public_html/global.php(607) : eval()'d code(255) : eval()'d code
              Line: 17

              Comment


              • #8
                Your hacks/addons are causing the problem.


                In your config.php file add: define("DISABLE_HOOKS", 1);

                This should cause the unable to add cookies message to stop.

                Comment


                • #9
                  Originally posted by Zachery View Post
                  Your hacks/addons are causing the problem.


                  In your config.php file add: define("DISABLE_HOOKS", 1);

                  This should cause the unable to add cookies message to stop.

                  Okay,

                  Plugins are currently globally disabled via config.php
                  However I get this error message at top of site:

                  Parse error: syntax error, unexpected '=' in /home/newage/public_html/global.php(833) : eval()'d code on line 10

                  I can see the site except the header at http://174.120.171.227/~newage/

                  Please help.
                  Last edited by New Age; Wed 11 Nov '09, 2:48pm.

                  Comment


                  • #10
                    What version of vBulletin are you running right now?

                    Comment


                    • #11
                      Originally posted by Zachery View Post
                      What version of vBulletin are you running right now?
                      vBulletinĀ® Version 3.8.4

                      Comment


                      • #12
                        I'd suggest putting it into a support ticket along with the relevant login info in the sensitive data box if you're still getting that with plugins disabled.
                        Vote for:

                        - *Admin Settable Paid Subscription Reminder Timeframe*
                        -
                        *PM - Add ability to reply to originator only*
                        - Add Admin ability to auto-subscribe users to specific channel(s)
                        - "Quick Route" Interface...

                        Comment


                        • #13
                          Can you login to the admincp?

                          eval('$header = "' . fetch_template('header') . '";');

                          Your header template has bad data in it.

                          Comment


                          • #14
                            Originally posted by Zachery View Post
                            Can you login to the admincp?

                            eval('$header = "' . fetch_template('header') . '";');

                            Your header template has bad data in it.
                            When I goto http://174.120.171.227/~newage/admincp/ it looks fine, However when I login the below error comes up then when my control panel is loaded the error message is gone.



                            Parse error: syntax error, unexpected '=' in /home/newage/public_html/global.php(833) : eval()'d code on line 10

                            Comment


                            • #15
                              You need to remove/change the contents of your header. Consider reverting the tmeplate.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X