Announcement

Collapse
No announcement yet.

Quick Reply not show

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick Reply not show

    hello to all


    I have problem in my forum my quick reply is not shown in Ordenary member and VIP member
    how can i fix this.. please help me

    here is the screenshot
    http://img148.imageshack.us/img148/622/snap350.png


    thanks in advance
    Attached Files

  • #2
    First, be sure that your forum has Quick Replies enabled in the AdminCP.

    Second, check your "SHOWTHREAD" template to be sure that this code is in there:

    Code:
    <!-- scripts for quick reply and quick edit -->
        $vBeditTemplate[clientscript]
        <if condition="$show['quickedit']">
            <script type="text/javascript" src="clientscript/vbulletin_quick_edit.js?v=$vboptions[simpleversion]"></script>
            <script type="text/javascript">
            <!--
            vB_AJAX_QuickEdit_Init('posts');
            //-->
            </script>
        </if>
    <!-- / scripts for quick reply and quick edit -->
    </if>
    
    
    <if condition="$show['quickreply']">
    <!-- quick reply -->
        <br />
        <script type="text/javascript" src="clientscript/vbulletin_quick_reply.js?v=$vboptions[simpleversion]"></script>
        <form action="newreply.php?do=postreply&amp;t=$threadid" method="post" name="vbform" onsubmit="return qr_prepare_submit(this, $vboptions[postminchars]);" id="qrform">
        <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
        <thead>
            <tr>
                <td class="tcat" colspan="2">
                    <if condition="$show['quickreply_collapse']"><a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('quickreply');"><img id="collapseimg_quickreply" src="$stylevar[imgdir_button]/collapse_tcat$vbcollapse[collapseimg_quickreply].gif" alt="" border="0" /></a></if>
                    $vbphrase[quick_reply]
                </td>
            </tr>
        </thead>
        <tbody id="qr_error_tbody" style="display:none">
        <tr>
            <td class="thead">$vbphrase[errors_occured_when_submitted]</td>
        </tr>
        <tr>
            <td class="alt1" id="qr_error_td"></td>
        </tr>
        <tr>
            <td class="tfoot" align="center"><span class="smallfont"><a href="#" onclick="return qr_hide_errors()">$vbphrase[okay]</a></span></td>
        </tr>
        </tbody>
        <tbody id="collapseobj_quickreply" style="$vbcollapse[collapseobj_quickreply]">
        <tr>
            <td class="panelsurround" align="center">
                <div class="panel">
                    <div align="$stylevar[left]" style="max-width:$stylevar[formwidth]; width:auto !important; width:$stylevar[formwidth]">
                        <div class="smallfont">$vbphrase[message]:</div>
                        <div id="$editorid" class="vBulletin_editor">$messagearea</div>
    
                        <fieldset class="fieldset" style="margin:$stylevar[formspacer]px 0px 0px 0px">
                            <legend>$vbphrase[options]</legend>
                            <div style="padding:$stylevar[formspacer]px">
                                <if condition="$bbuserinfo['signature']">
                                    <div style="float:$stylevar[right]"><label for="cb_signature"><input type="checkbox" name="signature" value="1" id="cb_signature" tabindex="5" checked="checked" />$vbphrase[show_your_signature]</label></div>
                                </if>
                                <label for="qr_quickreply"><input type="checkbox" name="quickreply" value="1" id="qr_quickreply" accesskey="w" tabindex="4" />$vbphrase[quote_message_in_reply]</label>
                            </div>
                        </fieldset>
                    </div>
                </div>
    
                <div style="margin-top:$stylevar[cellpadding]px">
                    <input type="hidden" name="fromquickreply" value="1" />
                    <input type="hidden" name="s" value="$session[sessionhash]" />
                    <input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />
                    <input type="hidden" name="do" value="postreply" />
                    <input type="hidden" name="t" value="$threadid" id="qr_threadid" />
                    <input type="hidden" name="p" value="$qrpostid" id="qr_postid" />
                    <input type="hidden" name="specifiedpost" value="0" id="qr_specifiedpost" />
                    <input type="hidden" name="parseurl" value="1" />
                    <input type="hidden" name="loggedinuser" value="$bbuserinfo[userid]" />
                    <input type="submit" class="button" value="$vbphrase[post_quick_reply]" accesskey="s" title="(Alt + S)" name="sbutton" tabindex="2" id="qr_submit" onclick="clickedelm = this.value" />
                    <input type="submit" class="button" value="$vbphrase[go_advanced]" accesskey="x" title="(Alt + X)" name="preview" tabindex="3" id="qr_preview" onclick="clickedelm = this.value" />
                </div>
    
                <div align="center" id="qr_posting_msg" style="display:none; margin-top:6px">
                    <img style="vertical-align: middle;" src="$stylevar[imgdir_misc]/progress.gif" alt="$vbphrase[posting_quick_reply_please_wait]" />&nbsp;<strong>$vbphrase[posting_quick_reply_please_wait]</strong>
                </div>
            </td>
        </tr>
        </tbody>
        </table>
        </form>
    
        <if condition="!is_browser('ie') AND $show['wysiwyg']">
            <!-- Mozilla work around for focusing on QR in WYSIWYG mode -->
            <div id="qr_scroll"></div>
        </if>
    
        <script type="text/javascript">
        <!--
            // initialize quick reply
            qr_init();
        //-->
        </script>
    <!-- / quick reply -->
    That should fix your problem...
    To be updated...

    Comment


    • #3
      the quick reply is enabled AdminCP -> vBulletin Options -> Message Posting and Editing Options -> Quick Reply -> Yes, Click Not Required


      i try to check this code to my show thread sir

      thank you once again

      Comment


      • #4
        this code is in there sir... complete but quick reply not shown


        Originally posted by ENF View Post
        First, be sure that your forum has Quick Replies enabled in the AdminCP.

        Second, check your "SHOWTHREAD" template to be sure that this code is in there:

        Code:
        <!-- scripts for quick reply and quick edit -->
            $vBeditTemplate[clientscript]
            <if condition="$show['quickedit']">
                <script type="text/javascript" src="clientscript/vbulletin_quick_edit.js?v=$vboptions[simpleversion]"></script>
                <script type="text/javascript">
                <!--
                vB_AJAX_QuickEdit_Init('posts');
                //-->
                </script>
            </if>
        <!-- / scripts for quick reply and quick edit -->
        </if>
        
        
        <if condition="$show['quickreply']">
        <!-- quick reply -->
            <br />
            <script type="text/javascript" src="clientscript/vbulletin_quick_reply.js?v=$vboptions[simpleversion]"></script>
            <form action="newreply.php?do=postreply&amp;t=$threadid" method="post" name="vbform" onsubmit="return qr_prepare_submit(this, $vboptions[postminchars]);" id="qrform">
            <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
            <thead>
                <tr>
                    <td class="tcat" colspan="2">
                        <if condition="$show['quickreply_collapse']"><a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('quickreply');"><img id="collapseimg_quickreply" src="$stylevar[imgdir_button]/collapse_tcat$vbcollapse[collapseimg_quickreply].gif" alt="" border="0" /></a></if>
                        $vbphrase[quick_reply]
                    </td>
                </tr>
            </thead>
            <tbody id="qr_error_tbody" style="display:none">
            <tr>
                <td class="thead">$vbphrase[errors_occured_when_submitted]</td>
            </tr>
            <tr>
                <td class="alt1" id="qr_error_td"></td>
            </tr>
            <tr>
                <td class="tfoot" align="center"><span class="smallfont"><a href="#" onclick="return qr_hide_errors()">$vbphrase[okay]</a></span></td>
            </tr>
            </tbody>
            <tbody id="collapseobj_quickreply" style="$vbcollapse[collapseobj_quickreply]">
            <tr>
                <td class="panelsurround" align="center">
                    <div class="panel">
                        <div align="$stylevar[left]" style="max-width:$stylevar[formwidth]; width:auto !important; width:$stylevar[formwidth]">
                            <div class="smallfont">$vbphrase[message]:</div>
                            <div id="$editorid" class="vBulletin_editor">$messagearea</div>
        
                            <fieldset class="fieldset" style="margin:$stylevar[formspacer]px 0px 0px 0px">
                                <legend>$vbphrase[options]</legend>
                                <div style="padding:$stylevar[formspacer]px">
                                    <if condition="$bbuserinfo['signature']">
                                        <div style="float:$stylevar[right]"><label for="cb_signature"><input type="checkbox" name="signature" value="1" id="cb_signature" tabindex="5" checked="checked" />$vbphrase[show_your_signature]</label></div>
                                    </if>
                                    <label for="qr_quickreply"><input type="checkbox" name="quickreply" value="1" id="qr_quickreply" accesskey="w" tabindex="4" />$vbphrase[quote_message_in_reply]</label>
                                </div>
                            </fieldset>
                        </div>
                    </div>
        
                    <div style="margin-top:$stylevar[cellpadding]px">
                        <input type="hidden" name="fromquickreply" value="1" />
                        <input type="hidden" name="s" value="$session[sessionhash]" />
                        <input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />
                        <input type="hidden" name="do" value="postreply" />
                        <input type="hidden" name="t" value="$threadid" id="qr_threadid" />
                        <input type="hidden" name="p" value="$qrpostid" id="qr_postid" />
                        <input type="hidden" name="specifiedpost" value="0" id="qr_specifiedpost" />
                        <input type="hidden" name="parseurl" value="1" />
                        <input type="hidden" name="loggedinuser" value="$bbuserinfo[userid]" />
                        <input type="submit" class="button" value="$vbphrase[post_quick_reply]" accesskey="s" title="(Alt + S)" name="sbutton" tabindex="2" id="qr_submit" onclick="clickedelm = this.value" />
                        <input type="submit" class="button" value="$vbphrase[go_advanced]" accesskey="x" title="(Alt + X)" name="preview" tabindex="3" id="qr_preview" onclick="clickedelm = this.value" />
                    </div>
        
                    <div align="center" id="qr_posting_msg" style="display:none; margin-top:6px">
                        <img style="vertical-align: middle;" src="$stylevar[imgdir_misc]/progress.gif" alt="$vbphrase[posting_quick_reply_please_wait]" />&nbsp;<strong>$vbphrase[posting_quick_reply_please_wait]</strong>
                    </div>
                </td>
            </tr>
            </tbody>
            </table>
            </form>
        
            <if condition="!is_browser('ie') AND $show['wysiwyg']">
                <!-- Mozilla work around for focusing on QR in WYSIWYG mode -->
                <div id="qr_scroll"></div>
            </if>
        
            <script type="text/javascript">
            <!--
                // initialize quick reply
                qr_init();
            //-->
            </script>
        <!-- / quick reply -->
        That should fix your problem...

        Comment


        • #5
          Originally posted by renskie View Post
          this code is in there sir... complete but quick reply not shown
          Well, I checked this in a test forum and it worked as I had instructed in my earlier post.

          You did check the "Message Posting and Editing Options" menu in the vBulletin Options section in the AdminCP?

          I can't think of anything else off-hand that would stop this from working. Is your skin a public one, or custom made by you? If it's publicly available, can you provide a link to it?
          To be updated...

          Comment


          • #6
            this is public skin sir..... the quick edit is working only in VIPmembers ,moderator. but in normal member they can't see the quick edit..

            please help me sir

            Comment


            • #7
              Let me clarify your comments again:

              You said earlier "Quick Reply" - Your last message says "Quick Edit".

              For those members that can't use the "Edit" function, you need to make sure that they have rights to do so in their respective user groups.

              Quick Reply and Quick Edit settings are right next to each other in the Message Posting and Editing Options menu in the vB Options menu. Both of these must be enabled first before Quick Edit and/or Quick Reply will work.

              - There is no user group option to control the Quick Reply box at that level. It's either enabled for the whole forum or it's not.
              - You can control editing at the user group level. Quick Edit, even if enabled in vB Options, won't work if the user group has no editing rights.

              I've attached to some screen shots to make sure we're talking about the same thing. -- Anything outside of these settings would point to a problem with your templates or something else all together.
              Attached Files
              To be updated...

              Comment


              • #8
                Sorry for the double-post:

                1) I found your forum. As a registered user, I can make posts/replies but I cannot edit them. If regular users are allowed to edit posts, you need to give rights for them to do so in your forum. (See attachment #1 in my previous post)
                2) Quick Reply appears to NOT be enabled. (See attachment #3 in previous post.)

                Thanks...
                To be updated...

                Comment


                • #9
                  im sory for the post number 6..

                  here's what i mean... all VIP member have quick reply option in there browser like this http://img245.imageshack.us/img245/5650/snap351.png

                  but in ordinary member can't see THIS OPTION ... i dont know why.. but when i use other name as ordinary member the quick reply is not shown as you see in THIS PICTURE all setting in Message Posting and Editing Options under vb option is ok see THIS PICTURE



                  thanks fir the reply sir

                  Comment


                  • #10
                    Well, I am baffled.... I cannot figure out why Quick Reply would not function for one group and not another as it is not controlled via a group setting.

                    As far as I understand it, the quick reply is either on or off for everyone. Does anyone else have any input on what the problem may be? I think I have covered everything possible that would affect these features.

                    I will look one more time and double-check my understanding of these features...

                    For the quick edit, your group option for editing posts still appears to be disabled based on the picture you provided. -- "You may not edit your posts"
                    To be updated...

                    Comment


                    • #11
                      in ordinary member they cannot edit thier post after the minute i allow to edit but in moderator and also supper moderator can do... my only problem is the quick reply not show in ordinary member... i check the setting in user group option all is ok but i dont know why still invisible on ordinary member.


                      anyway thanks your reply sir.

                      Comment


                      • #12
                        any other IDEA ?

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X