Announcement

Collapse
No announcement yet.

Attachment uploading/viewing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment uploading/viewing

    When attempting to upload small JPG (under 30Kb), receive the following:

    Fatal error:
    • A required field called filesize is missing or has an invalid value.
    Unable to proceed with save while $errors array is not empty in class vB_DataManager_Attachment_Database in [path]\includes\class_dm.php on line 810
    #0 vb_error_handler(256,
    • A required field called filesize is missing or has an invalid value.
    Along with a large amount of text.

    I've recently moved to a new server (Windows 2008 R2). I'm running PHP 5.3.0, MySQL 5.0.5.

    I've included my PHP.INI

    Items are stored in the database.
    Attached Files

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      One other thing I verified is that the file is being written to the tmp directory, since I uploaded a jpg, I renamed the .tmp file to jpg, and it was the correct file.

      It just doesn't appear to be writing it into the database.

      Comment


      • #4
        Steve -
        I've done a clean install of 3.8.4 PL1, and the problem still exists.

        Comment


        • #5
          Then this is a server issue. Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

          Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            http://www.templeofevil.com/adm/phpinfo.php

            Comment


            • #7
              Are you using GD or ImageMagick?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Using GD

                Comment


                • #9
                  Fill out a support ticket at:

                  http://members.vbulletin.com/members...ontactform.php

                  Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks, Steve. Information sent.

                    Looks like I need to get my VB 4.0 license purchased.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X