Announcement

Collapse
No announcement yet.

Log out problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Log out problems

    Just upgraded to vB 3.8.4, having problems logging out, cleared cookies from browser IE8, but won't let me log out.

    Cleared cookies 4/5 times now and restarted machine twice but still logged in, why?

  • #2
    Make sure your cookie path and domain are default:

    Admin CP -> vBulletin Options -> Cookies and HTTP Header Options

    The path should be "/" and the domain should be blank.

    Then try clearing your cookies again.

    Comment


    • #3
      Originally posted by Jake Bunce View Post
      Make sure your cookie path and domain are default:

      Admin CP -> vBulletin Options -> Cookies and HTTP Header Options

      The path should be "/" and the domain should be blank.

      Then try clearing your cookies again.
      Thank you - I tried that and still the same, so left the path to save cookies as "/" and the cookie domain I changed to the domain of the site, this enables me to log out but when logging back in, if I don't enable remember me it logs me out on page refresh (if I don't check the radio button , I am logged out on page refresh).
      outreacher
      Member
      Last edited by outreacher; Sat 3 Oct '09, 1:26pm.

      Comment


      • #4
        So the logout problem is fixed, but now the problem is that you can't stay logged in?

        1) The user will be automatically logged out if they are inactive for longer than the timeout:

        Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> Session Timeout

        To resolve this problem you can either increase the timeout or tell your users to check the Remember Me box when they login. That will automatically log them back in when they timeout.

        2) Many portals and other addons will modify login forms and links to use full URLs which can cause these kinds of login problems. Sometimes you can fix this by editing the cookie domain:

        Admin CP -> vBulletin Options -> Cookies and HTTP Header Options

        Try using a cookie domain like this (which uses your domain name, including the beginning dot):

        .domain.com

        That will make it so your forum cookies work from any subdomain of your domain, with or without "www". You will need to log out and login to your forum again for the changes to take effect. You may have to manually delete the cookies from your browser.

        3) Or maybe it's a caching problem. Try enabling this:

        Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> Add No-Cache HTTP Headers

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X