Announcement

Collapse
No announcement yet.

resolve (Image Verification Not Working) registertion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • resolve (Image Verification Not Working) registertion

    hi there

    I discovered today that the verification of human Broken (Version 3.8.3)
    I worked for about 5 hours,

    And reached to resolve the problem
    The solution is 2 step only >>>>>>


    STEP 1

    Search in the file register.php

    PHP Code:
        if (fetch_require_hvcheck('register'))
        {
            require_once(
    DIR '/includes/class_humanverify.php');
            
    $verify =& vB_HumanVerify::fetch_library($vbulletin);
            if (!
    $verify->verify_token($vbulletin->GPC['humanverify']))
            {
                
    $userdata->error($verify->fetch_error());
            }
        } 
    Replace
    PHP Code:

        
    if ($_REQUEST['do'] == 'addmember')
        {
            require_once(
    DIR '/includes/class_humanverify.php');
            
    $verify =& vB_HumanVerify::fetch_library($vbulletin);
            if (!
    $verify->verify_token($vbulletin->GPC['humanverify']))
            {
                
    $userdata->error($verify->fetch_error());
            }
        } 
    -------------------------
    STEP 2
    Search in the file register.php
    PHP Code:
        if (fetch_require_hvcheck('register'))
        {
            require_once(
    DIR '/includes/class_humanverify.php');
            
    $verify =& vB_HumanVerify::fetch_library($vbulletin);
            
    $human_verify $verify->output_token();
        } 
    Replace

    PHP Code:

        
    if ($_REQUEST['do'] == 'register')
        {
            require_once(
    DIR '/includes/class_humanverify.php');
            
    $verify =& vB_HumanVerify::fetch_library($vbulletin);
            
    $human_verify $verify->output_token();
        } 
    The solution in my fourm
    http://www.alastorh.com/vb/showthread.php?t=29481
    Best wishes alastorh.com (المطلوووب)
    Last edited by alastorh.com; Sat 3 Oct '09, 6:46am.

  • #2
    It deff did work!!

    I get this error though on top of the registration page:

    Warning: Missing argument 1 for vbrand(), called in [path]/includes/class_humanverify.php on line 176 and defined in [path]/includes/functions.php on line 357

    Warning: Missing argument 2 for vbrand(), called in [path]/includes/class_humanverify.php on line 176 and defined in [path]/includes/functions.php on line 357

    Comment


    • #3
      Originally posted by ctvtec View Post
      It deff did work!!

      I get this error though on top of the registration page:

      Warning: Missing argument 1 for vbrand(), called in [path]/includes/class_humanverify.php on line 176 and defined in [path]/includes/functions.php on line 357

      Warning: Missing argument 2 for vbrand(), called in [path]/includes/class_humanverify.php on line 176 and defined in [path]/includes/functions.php on line 357

      what is you'r fourm Version ?

      in Attachments i have upload register.php work's fine for 3.8.3
      you can try it

      Comment


      • #4
        Originally posted by alastorh.com View Post
        what is you'r fourm Version ?

        in Attachments i have upload register.php work's fine for 3.8.3
        you can try it
        It is against the license agreement to share vB files. That attachment has been removed.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          It is against the license agreement to share vB files. That attachment has been removed.
          Sorry Steve Machol about that

          it's my first posts as you can see

          Comment


          • #6
            i uploaded the files of the newest version.. and it still says that its 3.7 version..i had to upload the functions.php from the old version, private.php, showthread.php, and a few different ones cause the site kept getting errors..
            How do i fix this?

            Comment


            • #7
              hi ctvtec it's not right to but old version with new version you have to had all file same the forum version my solition is for 3.8.3 not for 3.7.x

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X