Announcement

Collapse
No announcement yet.

Fulltext search problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fulltext search problem

    hi guys
    i have problem with fulltext search
    when i`m using fulltext search i cnat search any mor
    and no more result
    when i`m using vbulletin search its ok
    what can i do ??
    and also i checked this one and i cant resolve my problem
    Code:
    Admin CP -> Forums & Moderators -> Forum Manager -> Edit Forum -> Index New Posts in Search Engine
    
    Also note that searches also use group permissions. If a user doesn't have access to view threads in a specific forum then the search will not find any results in that forum.
    
    Also check which search engine you are using:
    
    Admin CP -> vBulletin Options -> Search Type (on the left, not the right)
    
    If you are using fulltext then run a repair to ensure that the search index is up-to-date:
    
    Admin CP -> Maintenance -> Repair / Optimize Tables
    
    If you are using the vBulletin search engine then you can run a rebuild in your:
    
    Admin CP -> Maintenance -> Update Counters -> Rebuild Search Index
    this result for Fix Unique Indexes
    Code:
    Fix Unique Indexes
    Table access already has a unique index
    Table adminhelp already has a unique index
    Table attachmentpermission already has a unique index
    Table bbcode already has a unique index
    Table forumpermission already has a unique index
    Table moderator already has a unique index
    Table phrase already has a unique index
    Table pollvote already has a unique index
    Table postindex already has a unique index
    Table rsslog already has a unique index
    Table search already has a unique index
    Table subscribediscussion already has a unique index
    Table subscribeevent already has a unique index
    Table subscribegroup already has a unique index
    Table subscribeforum already has a unique index
    Table subscribethread already has a unique index
    Table subscriptionpermission already has a unique index
    Table tag already has a unique index
    Table template already has a unique index
    Table useractivation already has a unique index
    Table word already has a unique index

  • #2
    I see your site is in Persian. Do you have this problem with all search terms or just Persian? For example, try making a post in English and run a search for one of the English words.

    Comment


    • #3
      hello
      tank you about your replay
      yes i problem with Persian word and also when search something in English like (psp,psp gps)i cant find any things
      can u help me about resolve this problem
      this one is a big problem for me
      i try to fix it but i cant
      but i don't have any problem with vbulletin search (persian,english)
      i can search any thing in my forum like (psp,psp gps and ....)
      tank you about your help

      Comment


      • #4
        3 letter words like that are often below the minimum word length. For fulltext the minimum word length is a MySQL setting on the server which needs to be set by your host:

        http://www.vbulletin.com/docs/html/main/search_type

        After changing this MySQL setting you need to run a repair to update the indexes:

        Admin CP -> Maintenance -> Repair / Optimize Tables

        Comment


        • #5
          hi
          tank your about your help
          my problem about search 3 words is ok now i can search 3 and more words search in my forum(just English)

          i still have problem with search Persian word

          what can i do ?
          table collection latin1_swedish_ci
          collection latin1_swedish_ci
          MySQL connection collation:utf8-Unicode_ci
          Last edited by havard20009; Tue 29 Sep '09, 12:01am.

          Comment


          • #6
            I have dealt with search problems with multibyte languages before. They are often caused by the UTF-8 characters being stored as entities because of incorrect language settings on the forum. This thread has several settings you can check:

            http://www.vbulletin.com/forum/showthread.php?t=259250

            Especially check #1. This should be UTF-8.

            After fixing the language settings then new posts should be searchable, but there is no easy way to fix the old posts.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X