Announcement

Collapse
No announcement yet.

album picture permissions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • album picture permissions

    we have 'Can View Albums' set to yes but guest still cannot view pictures. am i doing it wrong?

  • #2
    If you are absolutely sure the permissions are set correctly for the Unregistered group, then this problem is from a modification.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      yea, same problem.

      Comment


      • #4
        it seems that i have to have 'Can View Member Info' set to yes too.

        i don't want profile's viable just the albums.

        Comment


        • #5
          If you do not have any add-ons installed, then fill out a support ticket at:

          http://members.vbulletin.com/members...ontactform.php

          Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            we don't use phpmyadmin or and only turn on ftp during upgrades.

            it seems i'm not the only one with this problem. it looks like it was first noticed in 3.7 and now 3.8. i doubt people change this option too often so maybe it's being overlooked.

            Reference this thread: http://www.vbulletin.com/forum/showthread.php?t=288883

            I know it's in the 3.7 forum but i see 3.8 users having the same problem in that thread.

            Comment


            • #7
              Assuming you do not have any add-ons installed then please fill out a support ticket for further help with this.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                don't be silly, steve. of course we have add-ons installed. everyone has add-ons installed. if you don't want to address a potential wide-spread issue then just say so. lol

                anyway, thanks for your replies. i'll be on my way now.

                Comment


                • #9
                  Actually only a minority of customers have third-party add-ons installed. You said you followed the instructions in post #2. If you did then you need to keep your add-ons disabled and fill out a support ticket. Otherwise you can try asking for help over at www.vbulletin.org.

                  And yes, I wish to address this issue if it can be confirmed on an unmodified vB with the correct permissions set. That is why I asked for the support ticket. Sorry if that was not clear.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    it's ok. i was just giving you a hard time

                    maybe i'll revisit this over the weekend. our members wouldn't like all of their extras missing while we wait for this to be addressed.

                    thanks

                    Comment


                    • #11
                      Originally posted by testbot View Post
                      it's ok. i was just giving you a hard time

                      maybe i'll revisit this over the weekend. our members wouldn't like all of their extras missing while we wait for this to be addressed.

                      thanks
                      like you, I'm not willing to disable my ad-ons while we trace down the problem.
                      Did you find a resolution ? Cause it don't work for my REGISTERED users. group, even tho it is set to allow them to see albums.

                      All my file versions, and even templates are VB-stock.. as I've coded all my mods into xml products.
                      -

                      Comment


                      • #12
                        Originally posted by svoec View Post
                        like you, I'm not willing to disable my ad-ons while we trace down the problem.
                        Did you find a resolution ? Cause it don't work for my REGISTERED users. group, even tho it is set to allow them to see albums.

                        All my file versions, and even templates are VB-stock.. as I've coded all my mods into xml products.
                        i disabled all of them and the problem still exists. i can't wait for a vbulletin support ticket though because that'll take too long and our members will complain the entire time.

                        to answer your question though, no, i did not find a solution.

                        i know the problem has nothing to do with the mods but unfortunately it's an easy out for them so i guess we'll never know. unless of course someone stumbles onto this and is willing to disable their mods for a few days or doesn't use mods.

                        oh well.

                        Comment


                        • #13
                          It's either permissions or a mod. There really are no other options.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            ok, disabled for 20 secs, while I ran a quick test...

                            results, STILL DON'T WORK

                            Ran the file suspect check, only came back with 5 files that weren't part of VB, all others were fine.
                            Attached Files
                            -

                            Comment


                            • #15
                              Here's a possibility. Since Albums are part of a user's profile, the Unregistered usergroup must also have 'Can View Member Info' set to 'Yes'. I have confirmed that this does work on a forum with no add-ons.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X