Announcement

Collapse
No announcement yet.

Auto redirects to profile.php and gives security token error?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Auto redirects to profile.php and gives security token error?

    Hi guys. I'm just starting to test out my new site, and it looks pretty good. One problem I am facing, is that when I first register for an account then go to the site, it tries redirecting me to my profile.php page, and gives me

    Your submission could not be processed because a security token was missing.

    If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

    Now, this seems to only happen to non verified users, so I don't know if that is a problem. if I refresh the page, the error goes away for that time, and I access the usercp.php page. I'm not sure if this is coding, but if it is, it sure is annoying.

    My site is here

    http://www.undertherotor.com/

    Thank you.

    EDIT: OK. I verified this test account, and it still happens. It also happens if I click "user CP" in both of the navbars.
    Last edited by iflymyhelishigh; Mon 31 Aug '09, 8:37pm.

  • #2
    Take a look at your page source and find the lines at the bottom of the page for the dst correction and see if that url is correct.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      Hmm, I am not sure what you mean.

      For now, I have the CSRF Protection disabled in only profile.php. This has seemed to clear up the issue temporarily.

      Comment


      • #4
        The page source is the html code for the page. Usually you got to View > Page Source in your browser.

        I noticed you can browse your site by going to either yoursite.com or www.yoursite.com and that may have something to do with the problem.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          Alright, is it possible to force www.?

          Comment


          • #6
            Originally posted by iflymyhelishigh View Post
            Alright, is it possible to force www.?
            Yes. You can either do it in http.conf or with htaccess.

            Redirect to www (htaccess redirect)

            Create a .htaccess file with the below code, it will ensure that all requests coming in to domain.com will get redirected to www.domain.com
            The .htaccess file needs to be placed in the root directory of your old website (i.e the same directory where your index file is placed)
            Code:
            Options +FollowSymlinks
            RewriteEngine on
            rewritecond %{http_host} ^domain.com [nc]
            rewriterule ^(.*)$ http://www.domain.com/$1 [r=301,nc]
            Please REPLACE domain.com and www.newdomain.com with your actual domain name.
            Note* This .htaccess method of redirection works ONLY on Linux servers having the Apache Mod-Rewrite moduled enabled.

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools <- awesome site for html/css help

            Comment


            • #7
              OK, I have added that text to my .htaccess file, and reenabled CSRF security. It seems to have cleared up now.

              Thank you very much.

              Comment

              Related Topics

              Collapse

              Working...
              X