Announcement

Collapse
No announcement yet.

vBulletin Fulltext Search

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin Fulltext Search

    Hello.

    I've switched a forum over to the fulltext search although I've noticed some keywords are no longer working now. For example if I search for 17-40L and it comes up with zero results.

    Any ideas why this might be?

    Tim
    Tim
    Nimbus Hosting
    www.nimbushosting.co.uk (vB Hosting Experts)

  • #2
    That would be considered two words: 17 and 40L

    Have you tried putting that in quotes?

    Note: MySQL fulltext search has a 4 character minimum word length by default. This can only be changed on the server level. There are also a number of 'stopwords' that are considered common and not indexed.

    Here are the instructions for changing the default 4 character minimum in MySQL's full text search indexing:

    http://www.vbulletin.com/forum/showp...57&postcount=7

    Here's the list of MySQL stopwords that will not be indexed:

    http://dev.mysql.com/doc/refman/5.0/...stopwords.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks Steve, even putting it in quotes is returning zero results.
      I feared the answer would be as you state, that it is being considered as two words.

      I wonder if there is any way to force the indexing of the "-" character as exactly that, a character not an operator (when indexing).

      Comment


      • #4
        Little bump. Is there any way of changing fulltext to index - as a valid character?
        If not, then we may need to revert to internal vb search for now.

        Comment


        • #5
          Sorry, I don't understand the question. Please explain.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Thanks Steve

            What I meant was that because the "-" character is treated as an operator, and not actually a character to search for...., was there anyway to force this

            Reason being, our forum contains alot of terms with "-" in them, so need to be searchable......

            We did revert back to internal vBulletin search again though so I suppose the question is moot now.

            Thanks anyway!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X