Announcement

Collapse
No announcement yet.

Error attaching video - Database error in vBulletin 3.8.4:

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error attaching video - Database error in vBulletin 3.8.4:

    WHen I try to upload a video as attachment (I've set my attachment size limit to this for 50MB - the video I'm attaching is only 5mb)

    I keep getting errors like this:

    Database error in vBulletin 3.8.4:
    Invalid SQL:
    INSERT INTO attachment
    (dateline, thumbnail_dateline, visible, userid, extension, filename, posthash, filehash, filesize, filedata)
    VALUES
    (1251227707, 1251227707, 1, 1, 'avi', '080724-timelapse-02.avi', '0d6400b4759483477ce2de42e041ed58', '4afd6a76874e18d5613532e182b35964', 5706014, 'RIFFW\0AVI LISTZ\0\0hdrlavih8\0\0\0W‚\0\0\0\0\0\0\0\0\0\0\0\0®\0\0\0\0\0\0\0\0\0†—\0\0Ð\0\0Š\0\0\0\0\ 0\0\0\0\0\0\0\0\0\0\0\0\0\0LIST‚\0\0\0strlstrh8\0\0\0vidsdivx\0\0\0\0\0\ [etc.... this garbage goes on for a long time]

    MySQL Error : Got a packet bigger than 'max_allowed_packet' bytes
    Error Number : 1153
    Request Date : Tuesday, August 25th 2009 @ 02:15:07 PM
    Error Date : Tuesday, August 25th 2009 @ 02:15:07 PM
    Script : http://www.ontariostorms.com/newatta...ageattach&p=57
    Referrer : http://www.ontariostorms.com/newatta...e2de42e041ed58
    IP Address : 216.221.65.71
    Username : Admin
    Classname : vB_Database
    MySQL Version : 5.0.45


    any ideas?

    Pictures upload no problem.

    And, on the same server, if I upload that video file to another one of my forums (3.6.8) it attaches it fine.

    What's possibly causing the error on my new forum (3.8.4) ???

  • #2
    This is a server issue. You or your host will need to increase the 'max_allowed_packet' in my.cnf, then restart MySQL. I recommend at least 32M for this setting. If that doesn't work, try 64M.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      This is a server issue. You or your host will need to increase the 'max_allowed_packet' in my.cnf, then restart MySQL. I recommend at least 32M for this setting. If that doesn't work, try 64M.
      I will ask around to find where that file is located - but wouldn't a server-wide setting also affect the other vB forums on that server? (that file uploads fine to my other forums) ??

      my /etc/my.cnf file looks like this:


      set-variable=local-infile=0
      datadir=/var/lib/mysql
      socket=/var/lib/mysql/mysql.sock
      # Default to using old password format for compatibility with mysql 3.x
      # clients (those using the mysqlclient10 compatibility package).
      old_passwords=1
      [mysql.server]
      user=mysql
      basedir=/var/lib
      [mysqld_safe]
      log-error=/var/log/mysqld.log
      pid-file=/var/run/mysqld/mysqld.pid


      ... 'not sure where that setting is ?? But like I said, I run a vb 3.6.8 and 3.7.4 also on that server, and this problem does not exist with them. ( ? )
      Last edited by z0diac; Tue 25 Aug '09, 1:10pm.

      Comment


      • #4
        Yes, it's a server wide setting. You would have to add the appropriate line to my.cnf
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          Yes, it's a server wide setting. You would have to add the appropriate line to my.cnf
          does this go under the [mysql.server] heading? I'm not sure where to put it in that file (my current my.cnf file is listed in a post above)

          And is this new for 3.8.4 ? I'm just not understanding why my other versions of vB aren't haven't this error.

          Comment


          • #6
            Add this to the top of that file:

            [mysqld]
            set-variable = max_allowed_packet = 32M


            Restart MySQL after making this change. Be sure to close your forums first.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              Add this to the top of that file:

              [mysqld]
              set-variable = max_allowed_packet = 32M

              Restart MySQL after making this change. Be sure to close your forums first.
              Thank you so much! I currently have a coder working on another one of my forums but I will enter that change as soon as he is done.

              ps - any reason why the other forums are accepting that file with no error and 3.8.4 gives the error ?

              Comment


              • #8
                Not really, no. Are you testing this with the exact same file?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  Not really, no. Are you testing this with the exact same file?
                  Yes - that's why I'm thinking it's not a setting in my.cnf - the exact file uploads and attaches fine to my other forums.

                  Comment


                  • #10
                    Well it is that setting. The error you got confirms that.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      ACCK! I think I might know why this is happening.

                      I just installed this vB last night - and it might default to having attachments in DATABASE instead of filesystem (which is what it should be and is what the other forums are set to).

                      I can't seem to find this setting? If I recall from my other vB's, there used to be a setting to store attachments in either database or file system. I've clicked "Show all settings" and did a search for 'attachments' but nothing has come up allowing me to enter what type to use.. ( ? ) EDIT: FOUND IT (in the attachments storage type on the left) Ok, will try again now.

                      Comment


                      • #12
                        WORKING.

                        Yes, it was because vB defaults to using the database to store attachments, and my other forums are set up to store in filesystem.

                        PHEW.

                        (thanks for your help though Steve!)

                        Comment


                        • #13
                          That's good to know.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by z0diac View Post
                            WORKING.

                            Yes, it was because vB defaults to using the database to store attachments, and my other forums are set up to store in filesystem.
                            Hey Zodiac,
                            I'm having the same problem here. Can you tell me, how do I find the attachment directory...or do I create an attachment directory and set it in vbulletin?
                            Any help appreciated.
                            Cheers
                            Simon

                            Comment


                            • #15
                              You should really start your own thread rather than digging up an old one...

                              However, you need to go to:

                              AdminCP > Attachments > Attachment Storage Type

                              You should have the option there - Move Items from Database into File System

                              Click 'Go' and on the next screen, set the path to the directory you want making sure that:

                              1. It exists! (use an FTP program to create one) and
                              2. It has the relevant permissions (usually 0777)
                              Vote for:

                              - *Admin Settable Paid Subscription Reminder Timeframe*
                              -
                              *PM - Add ability to reply to originator only*
                              - Add Admin ability to auto-subscribe users to specific channel(s)
                              - "Quick Route" Interface...

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X