Announcement

Collapse
No announcement yet.

Missing phrases

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing phrases

    Hello,

    I upgrade my MySQL version yesterday and I start notice today a few phrases missing, admin panel and front end.

    Cases like this on the admin panel:

    Could not find phrase 'all_phrases_are_up_to_date'.

    or

    Could not find phrase 'no_phrases_matched_your_query'.

    or also every time a new user register on the forum I receive an email with this message:

    Could not find phrase 'newuser'.

    I'm using my vbulletin in Spanish and I already re-upload it the language file.

    What else could be wrong? or How can I fix this?

    Thanks in advance for your help on this matter.

    Jesus

  • #2
    Try this. Reupload the original vbulletin-language.xml file to the install directory. Then upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Then reimport the vbulletin-language.xml file. Immediately remove tools.php when you are done.

    Then run this in the Admin CP:

    Admin CP -> Languages & Phrases -> Language Manager -> [Rebuild All Languages]
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve thanks for your answer,

      I tried to re-upload the english lang file and receive this error message:


      Database error in vBulletin 3.8.0:

      Invalid SQL:

      UPDATE vb3_phrase SET
      languageid = -10
      WHERE languageid = -1
      AND (product = 'vbulletin' OR product = '')
      AND vb3_phrase.fieldname NOT IN ('cphelptext');

      MySQL Error : Incorrect key file for table './t_foros/vb3_phrase.MYI'; try to repair it
      Error Number : 126
      Request Date : Monday, August 17th 2009 @ 11:45:22 AM
      Error Date : Monday, August 17th 2009 @ 11:45:23 AM
      Script : http://www.xxxxx.com/foros/adminpane....php?do=upload
      Referrer : http://www.xxxxx.com/foros/adminpane...e.php?do=files
      IP Address : 201.172.181.168
      Username : Myusername
      Classname : vB_Database
      MySQL Version : 5.0.51a-max

      Any ideas?

      Thanks for poiting me to the right direction!

      Jesus

      Comment


      • #4
        To fix this run Repair/Optimize in the Admin CP. You may need to run it more than once to fix all errors:

        Admin CP -> Maintenance -> Repair/Optimize Tables -> Check All -> Continue

        If you cannot access the Admin CP you can also use phpMyAdmin to repair tables.

        If that doesn't work then this may be too damaged to fix with the normal methods. Please check out this thread for other ways to repair a db, particularly items #2 and 3:

        http://www.vbulletin.com/forum/showt...threadid=44909

        You may have to ask your host to try and repair this for you.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          If you have an active license try to update to vB 3.8.4, as I see you using 3.8.0

          Comment


          • #6
            Hi Steve,

            Got this message after trying to repair tables:

            vb3_phrase Check Error: Table upgrade required. Please do "REPAIR TABLE `vb3_phrase`" to fix it! vb3_phrase

            Comment


            • #7
              Originally posted by dlg View Post
              Hi Steve,

              Got this message after trying to repair tables:

              vb3_phrase Check Error: Table upgrade required. Please do "REPAIR TABLE `vb3_phrase`" to fix it! vb3_phrase
              Do it from your phpMyAdmin Panel

              Comment


              • #8
                Hi Sysop9001, thnaks for your help

                There's a message that says In Use on that table, should I stop/restart MySql server before continue?

                Comment


                • #9
                  You need to use one of the stronger repair methods in the link I posted.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    I tried No. 1 and No.2 already with no luck the same table continue to give me error.

                    Will try to contacto my host and fix this thing ASAP.

                    Thanks for all your help!

                    Jesus

                    Comment


                    • #11
                      Just an update.... I delete the table and use my backup to create the table again and did the proper restore. Everything seems fine now.

                      Thanks for your help!

                      Jesus

                      Comment


                      • #12
                        Originally posted by dlg View Post
                        Just an update.... I delete the table and use my backup to create the table again and did the proper restore. Everything seems fine now.

                        Thanks for your help!

                        Jesus
                        Good News

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X