Announcement

Collapse
No announcement yet.

Attachments problem after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The limits on some usergroups are set a maximum size of over 5Mb, others over 10Mb and staff is unlimited (0). The problem here, for instance, is some staff can not upload at all but some can with no problem. This is the case for other usergroups too. Nobody has custom set permissions (only admins), all permissions are set at the usergroup level.

    The files to be uploaded are always the known type: zip, rar, pdf, jpg.

    When I start testing this problem, I disabled all plugins one by one. Then I used to global option to disable it in the Vbulletin options//Plugin/Hook system.
    To me it looks rather a problem at the db level or some PHP code is screwed up, but I may be very well wrong.
    Please help.

    Comment


    • #17
      So some people cannot upload any file regardless of file size and others can? Assuming they are in the same usergroup then the only way I can see this happening is from an add-on.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        Yes, that is correct Steve.

        If that is from some add-on, please tell me what can I do.

        Comment


        • #19
          To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

          Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

          [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

          Next, disable all plugins.

          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

          define('DISABLE_HOOKS', true);


          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

          Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #20
            - I have uploaded all non-image files from all forum, overwriting the existing ones. In the FTP program, all files were set to upload only in ASCII mode.

            - Ran the "Suspect File Version" and no file had "File does not contain expected contents". However, I had some XML files in XML folder that were listed (from two hacks, chatbox and thanks button). I have removed those XML files and ran the diagnostic again. All seems to be OK. Please take a look at the pic attached.

            - Edited the config.php and added "define('DISABLE_HOOKS', true);", then confirmed that all plugins are disabled.

            - Created a new style. logged off, clean the history and cookies, closed the borwser, logged back on under the new skin, and as regular member(not admin) and tried to attach some files in a newly created thread. The error is the same! Please see the attached pic.

            I don't know what else to do...

            To be mentioned that few days ago I've raided a trouble ticket because the upgrade from 3.8.1 to 3.8.4 did not go smooth and in fact created a new forum with a new database. You told me what to do and I fixed it in no time. Is it possible that issue to be connected with the current headache?
            Attached Files

            Comment


            • #21
              I'm afraid we would probably need root access to this server to investigate this further. I suggest asking your host to check the server error logs to see if they can find something.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #22
                The host can not find anything out of usual. What could we do next please?

                What I don't understand is how a setting or a mistake at the server level could affect a forum so that some members could attach and some not?

                Comment


                • #23
                  Sorry but we would need root access to this server to investigate this further.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #24
                    I have asked the host to look again. If they can not find anything, I will get back to you.
                    How should I proceed please, open a support ticket with the required server login?

                    Comment


                    • #25
                      Yes, assuming your host will grant root access which is not likely.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #26
                        Hello again,

                        Since I lease the server I could provide the root login.
                        The host support looked into it and found nothing. They noticed that the database attachments folder (that is set outside of database in a separate folder) had problems. They said: "When we check the permission was 755 and most of the file permission on the account was all messed up. We set all at 777 and now it is working fine."
                        I did confirmed and indeed all users could post now.

                        I do not know what could caused this "messed up", the attachment feature did work fine for years. What would be the reason for a folder or group of folders to change the permissions without human intervention? Or was it that in one point when the forum needed to make a new folder for new set of attachments, it was made/generated with wrong (more restricted) permissions, therefore when a new attachment was generated it could not be written in that folder or folders set? Is this possible? If yes, it means I could experience this in the future, right?

                        Anyway, what should I do please? To leave the entire db attachments at 777 is not safe, right?

                        Comment


                        • #27
                          If you are storing attachments in the file system then this has always required 777 permissions. Maybe someone changed them.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #28
                            Originally posted by Steve Machol View Post
                            If you are storing attachments in the file system then this has always required 777 permissions. Maybe someone changed them.
                            So the entire folder with all subfolders require to be 777? If that is the case, isn't for a hacker relatively easy to erase the folder? Isn't 755 better?

                            Comment


                            • #29
                              That is why we recommend placing this above the web directories. Nonetheless this is optional. You can still use database storage if you are concerned about this.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment


                              • #30
                                I have almost 6Gb of attachments and that is the reason I moved them outside of the db. Wouldn't be a problem to move the attachments to a directory in /home/ ?

                                What should I do to change it please?
                                Go to /admin cp/Attachments/Attachments Storage Type/ and select "Move Items to a Different Directory" by defining the directory 777 in the /home/ ?
                                Considering that I have already created the directory in home with 777 permissions.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X